powered by Jive Software

Spark beta will not run as standard user

Hi,

I know this question has been asked many times but there doesn’t seem to be any definitive answers.

We have recently upgraded all our client machines to Windows 7 (32bit Enterprise) and are having trouble getting Spark to run under a normal user account. It will only launch if run by an Administrator (local or domain) or by using the “Run As Administrator” context menu. This isn’t suitable as Spark runs as the account that launches it - ie the spark logs are created under the admin userprofile folder.

I’ve tried using an MSI package - same result. I’ve tried deleteing all folders and settings related to Spark and manually installing Spark and it still does not run.

Why does it need to run as an administrator? Is it Spark or Java causing this? When other programs have shown this problem I can just give appropriate user/group access to HKLM registry keys or folders and this fixes the problem. I can’t see why Spark needs to run as an administrator.

This is (obviously) a real show stopper. Is there a real world solution or are people using other clients?

I’d appreciated any advise or pointers.

Cheers,

Ben

Beta was released before Windows 7 and i believe it hasn’t even been tested on Vista. You can try one of the latest SVN code installers from here http://www.igniterealtime.org/community/docs/DOC-1822 Though it may have other issues. Other clients you may try are Pidgin, Psi, Miranda, Exodus and many others (http://xmpp.org/software/clients.shtml).