Spark calling home?

Why does spark when I log in call home to How do I stop this behavior? I really like spark but we won’t be able to implement this if it calls home like that…

I don’t think it’s calling home, I think it’s just figuring out it’s network settings using the STUN protocol, and the STUN server you mentioned.

Read this from the openfire STUN console page:

"STUN is a protocol that lets clients discover their network settings, including firewall and NAT device configuration. Use of the protocol is required for clients to establish peer to peer media sessions. "

I’ll check that, but whats weird is the host name was not set in the external stun servers.

Sorry, Still calling home to xtunnel1. It’s definitely spark doing to because Miranda doesn’t have this ‘problem’.

It just may be a url built into Spark.

I still wouldn’t call this “calling home” since it actually isn’t calling “home”. Counterpath is a completely seperate entity from igniterealtime or jive software. They actually are a commercial software company specializing in voip software. Perhaps you have a voip plugin enabled in Spark?

nope, not at all.

Its connecting to a STUN server. In the openfire console, go to the STUN settings. There is (by default) a list of servers to use. is one of the defaults, which resolves to the same IP address as Simply delete all the STUN servers in the list and you should be good to go. You might need to restart openfire, but Im not 100% certain of that.


the STUN server is hard coded in SMACK as a fallback server. Without changes in SMACK, it will always connect to the server