powered by Jive Software

Spark client SSO on Server 2008r2

I have successfully set up Openfire 3.9.1 on a Windows 2003 server; and can connect Spark 2.6.3, using SSO, on Windows 7 and Windows 8.1 domain computers.

Thanks @Slushpupie!

Half of my users use Remote Desktop to connect to a Windows 2008r2 server, and I cannot seem to get them to connect using SSO.

If I disable SSO in the Spark client, I can enter the username/password to connect.

The firewall is off for the domain; I have added Spark to the list of allowed programs to be sure.

I have added the AllowTGTSession registry entry

I have the KRB5.INI file in the windows directory.

I copy a Spark.properties file into the users’ appdata folder for the initial setup.

I have noticed that in the users’ “%userprofile%\appdata\spark” folder, that when Spark is loaded, it doesn’t add the rest of the config folders (Maybe this is part of the issue? Though, manually adding the files does not help either)

Is there something I missed, to enable kerberos on a 2008r2 terminal server?

are your users using a VPN to connect through? Is it using split tunnels? Perhaps your VPN is not allowing port 5222 traffic through (the port Spark and Openfire need open to talk to each other)?

No VPN

I may have it working:

I had to put the KRB5.INI file in the C:\ (not c:\Windows)

I’ll close this discussion if I can repeat the results