Spark Compilation problem


I followed the documents in order to get spark and to be able to compile it. I had a try on both Net Beans and Eclipse. But I allways get the same error on the code and I can’t find why.

On quasily every package it tells me that : “Incorrect Package”.

Ie : “package org.jivesoftware;” is red underligned and when I put my cursor on it it tells me “incorrect package”.

It really makes me confused because I spent a lot of time on tries but no way to make it work. If I try to compile it, it generates the bat file but the bat doesn’t invoke spark.

Anybody has an idea ?

Thank’s !

Strange. I got it working with NetBeans on the first try and never had seen such errors. Have you modified anything in the source? Maybe it’s corrupted and you should redownload the source.

Okay, thank’s for your answer, I have redownloaded the source code, now I’m able to compile it (without the plugins, cause the packages seems not to be linked : packages likes com.jivesoftware/…).

I’m under jdk 1.5 (I tried also the tried with the jdk 1.6) and net beans tells me that during the compilation :

Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.

However, the startup.bat file is generated but when I try to launch it, it returns me that error :

Exception in thread “main” java.lang.NoClassDefFoundError: org/jivesoftware/laucher/Startup

If I try compiling with the jdk 1.6 the error that I get while trying lauching the startup.bat is :

Unsupported major.minor version 49 (my java_home variable is pointing to a jre 1.6)

Anyone has an idea ?

I finally had a try with Eclipse and I had some problem that are exactly the same than the ones that are related in the post before the last one in this thread

It’s due to I don’t know which package to add to the path. Java tells this class is implemented since 1.4 and i’m working on 1.5 or 1.6

Anyone has an idea ?

Okay I’m getting closer … Now my problem whan I try to build is :

Buildfile: C:\Program Files\eclipse\Spark\build.xml
[taskdef] Could not load definitions from resource net/sf/antcontrib/ It could not be found.

C:\Program Files\eclipse\Spark\build.xml:16: taskdef class cannot be found

Total time: 320 milliseconds

The packages appears into the path and the path written in the build file seems to be correct.

Here’s the part of the build.xml file that is in question :


I’m having the same error. Were you able to resolve this ?


Buildfile: build.xml

file:/local/mnt/workspace/a2m/openfire_src/build/build.xml:45: taskdef class cannot be found

The required JAR file is located in the lib subdirectory


ls lib/pack