powered by Jive Software

Spark Crash on Advanced Login Settings

Hy

I am running an Spark Client. It runs good but when i press the button “Advanced” on login screen then spark crash and i must restart spark.

When i press the login button, i can login and use spark.

I will change the login to the sso method, on an other client it works fine but my client crashs.

The problem client is an windows xp 64bit os, the working client an windows xp 32bit.

thx for helping

busdi

Hy

oh no one with the same problems? or ideas to fix it?

The problem is on 3 Windows XP 64bit Clients.

Spark Client crashs when i press the “Advanced” button on login screen.

Any ideas? Ideas to find where the problem is?

When I enter the sso login option in the config file spart wont start, must i edit the registry to use the sso?

thx for all your help

busdi

Hi Busdi,

you could try to start Spark with Spark.cmd start script and set the Direct 3D parameters. Do you get a Javacore file (located somewhere in the Spark directory) when Spark crashes? It should contain some useful information.

LG

Hy

thx for helping

I run the cmd script and tested all 3 parameters (-Dsun.java2d.ddoffscreen=false -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=true) but it crashs again.

I run the cmd script with the debug funktion (“C:\Program Files (x86)\Java\jre1.6.0_05\bin\java.exe” -Xms16m -Xmx16m -XX:NewSize=4m -XX:MaxNewSize=4m -XX:PermSize=16m -XX:MaxPermSize=16m -XX:+PrintGCDetails org.jivesoftware.launcher.Startup %autologin%)

in Attachment the Screen dump.

And i think i found the core file in Spark directory. In Attachment too

“But i cant read the files.”

Hope anyone can read the files and help me.

thx busdi
Spark-Screendump.txt (11709 Bytes)
Spark Core-hs_err_pid2480.log (10082 Bytes)

Hi,

your files contain both:

  1. EXCEPTION_ACCESS_VIOLATION …

  2. Problematic frame:

  3. V http://jvm.dll+0xdfa75

Current thread … JavaThread “AWT-EventQueue-0”

So there is a problem with the jvm.dll, this is quite hard to fix.

You may first want to review Spark crashes on login.

As you are using JRE 1.6.0_05 you should update the JRE to 1.6.0_06 or 1.6.0_10-beta and try to reproduce the issue. If this happens again you can submit a bug report to Sun.

LG

Did you ever get this resolved? Did LG’s last suggestion work? I have the same problem so I’d like to know what your fix turned out to be (if you found one). Thanks!

I would like to know this as well, I am having the same crash problem on XP64.

I would like to know this as well. I’ve got it happening on a Win 2k3 x64 Terminal Server. Here’s the kicker. If I login to the account as the local machine admin, I can bring up that ADVANCED window. However, if I login with any domain accounts, it crashes when I press ADVANCED.

In my case, my ultimate goal is to just pre-enable the autofind server and SSO options so users can just run the program w/o needing to initially configure it.

Kris

Hi Kris,

it may be more easy to create the configuration files (and if needed registry entries) for every Spark user than strarting and configuring it for every user manually. Running it on a terminal server may be a bad idea as Spark needs about 64 MB memory.

LG

Normally I’d agree, but I’m a noob, so not entirely sure how to. And for the terminal server part, not too worried about it, 32 GB server for 16 users. Pleanty of room/ram.

Kris

Hi,

everything should be stored in “%USERPROFILE%\Spark”.

Does the JVM write a hs_err-file when Spark crashes?

LG

Problem exists on all my Win2003 x64 machines as well.

A fatal error has been detected by the Java Runtime Environment:

EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x78aa1ed7, pid=3812, tid=2812

JRE version: Java™ SE Runtime Environment (7.0_51-b13) (build 1.7.0_51-b13)

Java VM: Java HotSpot™ Client VM (24.51-b03 mixed mode windows-x86 )

Problematic frame:

C [MSVCR100.dll+0x1ed7]

I’ve tried different clients: spark 2.5.x, spark 2.6.x, spark 2.7.x

also different java version. Always the same error.

Likely a problem with the used dll. Anyhow Spark does usually not run on servers - so I have no idea whether this is a win2003 problem or a problem with your setup.