powered by Jive Software

Spark crashes after login

I receive this error when trying to login to Spark 2.8.2 on an Embedded XP system that runs on a CNC machine. Had the same issue with 2.7.7. The server and various clients work on other systems. I can post the rest of the error log if needed. Any input much appreciated!

A fatal error has been detected by the Java Runtime Environment:

EXCEPTION_ILLEGAL_INSTRUCTION (0xc000001d) at pc=0x679c8fe9, pid=3392, tid=0x000005f4

JRE version: Java™ SE Runtime Environment (8.0_112-b15) (build 1.8.0_112-b15)

Java VM: Java HotSpot™ Client VM (25.112-b15 mixed mode windows-x86 )

Problematic frame:

C [jnportaudio.dll+0x8fe9]

Failed to write core dump. Minidumps are not enabled by default on client versions of Windows

If you would like to submit a bug report, please visit:

http://bugreport.java.com/bugreport/crash.jsp

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

OS: Windows 5.1 Build 2600 (5.1.2600.5781)

CPU:total 1 (1 cores per cpu, 1 threads per core) family 6 model 11 stepping 4, cmov, cx8, fxsr, mmx, sse, tsc

Memory: 4k page, physical 490992k(84480k free), swap 1150468k(758380k free)

vm_info: Java HotSpot™ Client VM (25.112-b15) for windows-x86 JRE (1.8.0_112-b15), built on Sep 22 2016 21:03:20 by “java_re” with MS VC++ 10.0 (VS2010)

It runs ok in my WinXP virtual machine. You can try removing this jnportaudio.dll from Spark\lib\windows\ folder and see if it has any effect. This is probably part of Spark’s media framework (used for audio chat). Maybe it can’t find some driver and crashes, as embedded system is minimalistic.

You can also check Spark’s logs, though it might be crashing before being able to log something in there. C:\Documents and Settings\User\Application Data\Spark\logs

Deleting the two dlls did nothing. Resolved it by disabling sound service.

How did you do that?

Disabled Windows Audio in the Services manager.

I see. You can probably now disable sound device in File > Preferences > Media settings and re-enable Windows Audio service, if you need it for something else.