powered by Jive Software

Spark fails to automatically reconnect

I have some users (with laptops) that disconnect from the wired network connection at their desk (typically to go to a meeting), then reconnect to the network by enabling the wireless (while in a meeting). Several of these users are experiencing issues with Spark not automatically reconnecting when going between a wired and wireless connection, and vice versa.

Of course, I try to duplicate the issue on my laptop and everything works as it should. I have tried several different scenarios that include different time periods between going from wired to wireless and from wireless to wired, standby and no standby between switching connections, etc…

Currently, the work-around I have given users when Spark does not automatically reconnect, is to go the “Spark” menu and click “Log out”, then login again.

Openfire version: 3.6.4 (CentOS 5.3)

Spark version: 2.5.8 (Windows XP)

Any help would be greatly appreciated!

–Curt

As you cant reproduce it all the time it is hard to suggest. You can try using 2.6.0 Beta 2 version or even newer from here http://www.igniterealtime.org/community/docs/DOC-1822 on some problematic laptop.

Are there any log files I can provide, or debugging that I can enable that would indicate why Spark is not automatically reconnecting on some laptops.

You can check C:\Documents and Settings\User\Spark\logs though dont think there will be much useful info.

Are there any back-end settings that I can change/add that would force the Spark client to “Log Out” then “Log In” if it fails to automatically reconnect or if there is an error during the login?

I havent heard about this. Probably this is possible by changing the source.