powered by Jive Software

Spark fails to start

Hello to all.

I just installed Wildfire on a CentOS 4.1 box, and also enstalled Spark on my Windows XP SP2 box. When I try to start Spark, I get an hourglass for a few seconds, then nothing. When I try to unintsall the program, I get the following error message:

The JVM could not be started. The main method may have thrown an exception.

So, I deleted the program, and went through the Windows registry to try and remove as many references to Spark as possible. I then tried installing the non-jvm version of Spark - same results (including the uninstall error message).

Hmmm. Anyone got any ideas as to what’‘s going on here and how to fix? Failing that, I’‘ve also installed the Exodus IM client, but don’'t know how to configure it to access the Wildfire server (port to connect to, etc.). Help would be greatly appreciated.


Hi diggy,

Which version of Spark did you install? The JRE or NON-JRE version? Also, could you look in the logs directory of Spark to see if there are any error.log or warning.logs?



Hey, Derek.

I tired the JRE version of 1.0.3 first, then the non-JRE version. Here’'s the output of the error log:

Exception in thread “AWT-EventQueue-0” java.lang.NullPointerException

at javax.swing.MultiUIDefaults.getUIError(Unknown Source)

at javax.swing.UIDefaults.getUI(Unknown Source)

at javax.swing.UIManager.getUI(Unknown Source)

at javax.swing.JPanel.updateUI(Unknown Source)

at javax.swing.JPanel.(Spark.java:44)

at com.jivesoftware.Spark$1.run(Spark.java:126)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

Sorry, I should have thought to post that in the op.


Sorry for replying to my own post, but …

I did get the Exodus IM client working with Wildfire - it was trivial, really, and works great. However, I’'d still like to get Spark working. Has anyone come up with any ideas as to how to fix the problem I described above?

Many thanks.


Hi Diggy,

If you have java installed, can you try to run Spark from the web? Just click on this link here.


Let me know, since this could be an installer issue.



That worked! What next?



Since Spark ran for me from the Web, is it an installer issue? If so, is an update or patch in the works. I don’‘t mean to be a pain, I’'d just really like to make it work on my system.

Many thanks.


Hi Diggy,

It is an installer issue and I’‘m trying to get a fix from the company. I’'ll keep you updated on this.


Many thanks. I’'ll look foirward to it!


Just an additional note on this.

I had a similar issue with a couple of my users but the issue seemed to be related to their profiles/rights. Example, Spark would not start with one users credentials but when I did a runas with another users credentials it started up fine. Both users had equal rights on the machine.


Any update on this issue?

brimur, in Windows XP, Spark will not run unless you enable users to write to the Spark folder.

ddman, shouldn’'t this be covered by SPARK-79?

Thanks pornsak but I do not believe that is the issue, some of the users I rolled it out to were admins on their PCs and had full access to the Spark folder. This is the error from one of the users error log file


at javax.swing.MultiUIDefaults.getUIError(Unknown Source)

at javax.swing.UIDefaults.getUI(Unknown Source)

at javax.swing.UIManager.getUI(Unknown Source)

at javax.swing.JPanel.updateUI(Unknown Source)

at javax.swing.JPanel.(Unknown Source)

at com.exe4j.runtime.LauncherEngine.handleFailure(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.exe4j.runtime.WinLauncher.main(Unknown Source)

Oh, so it is a different case then. But Spark (1.0.4) did not start in my case unless I allow the user to write to the Spark folder.

is your server working correctly, did you enable the ports/services that wildfire uses in your /etc/services file.

jabber 5222/tcp # Jabber-Jive Messenger

jabber 5222/udp # Jabber-Jive Messenger

jabbers 5223/tcp # Jabber-Jive Messenger (secure)

jabbers 5223/udp # Jabber-Jive Messenger (secure)

Wildfire communicates on UDP port?

I’‘m the OP. I’‘m running Wildfire on a CentOS 4.1 box. It was easy to set up, and a great program. When I couldn’‘t get Spark to install on my Win XP SP2 boxes, I installed the Exodus client instead. It works perfectly. The moral of the story is that the server is set up just fine. It’‘s the Spark client that’‘s the problem. Derek has indicated that it’‘s a Spark installer issue. Here’'s hoping a fix will come soon, as I would think/hope that the Wildfire/Spark combination coming from the same developers (I think) would provide some kind of added benefit.

i’'m not sure if it requires those udp ports accessible. Perhaps someone with some linux skills could let us know.

Hi Orlando,

very interesting to see that also the UDP ports are reserved for Wildfire according to your “/etc/services” file. It looks more like an entry you made, otherwise “XMPP” should be mentioned there and not “Jive Messenger”. Anyway I think they can be used very good for video/audio transmissions.


Hi, folks.

I hope I’‘m not being a pita, but I just can’‘t seem to get Spark to work on either my Windows XP box or my SimplyMepis linux box. In the first instance, I removed Spark manually, as the uninstalled complained about something having to do with Java. I also went through the registry and removed every instance of Spark. Then I installed the new version. Same problem - program just never opens (this after I see the Windows hourglass for a brief time, then nothing. On the linux end, I untarred/unzipped the file. Thought I’‘d have to compile it from there, but there are no compilation files. Ok, as I don’'t readily see another option, I guess I run ./Spark. I get the following:

ls: /usr/local/Spark/lib/windows: No such file or directory

followed by a bunch of java and X11 display errors.

Arrrrrgh! Am I stupid, or missing something, or what. Help would be greatly appreciated.