Spark Idle Priority Question

I have Spark installed on a Windows machine 7 x64 machine. The Idle Timeout works correctly and the presence goes to “Away”, but the priority stays at 1. If I physically set the status of my client to “Away”, the priority does goes to 0. I would assume that if the timeout occurs that the priority should also be set to 0 automatically, but that is not happening.

Is this by design? Does anyone know how to enable the priority to go to 0 when the client goes into idle?

Thank you,


I don’t know whether it was done by default, but i will file it as a bug, because i think it should behave the same. SPARK-1564. Until someone provides a patch fixing this, i think there is no other option to change this.

Fixed [SPARK-1564] Should set priority to 0 when Idle status turns on - IgniteRealtime JIRA Should be included in 2.8.0 version.