powered by Jive Software

Spark in Offline/Online Status Limbo


#1

Hey guys, we’ve been having a extremely weird issue with Spark for a while now.

We are on OpenFire 4.2.1 (Yes, I know I need to upgrade and am working on that). In the field we use mostly Spark 2.8.3 and Pidgin for a handful of users. In 90% of situations, our spark users are connected to the VPN when using spark for chat.

We’ve had a very intermittent issue that seems to be related to network blips. The places that our field users are connected have very shotty connections sometimes and disconnecting/reconnecting to the VPN isn’t uncommon. The issue is that sometimes when a slight VPN blip happens, Spark seems to disconnect but still appear online. Even after the VPN connection reconnects it doesn’t sort itself out. The user doesn’t get an error that there’s a connection issue so they continue sending messages. The problem is that when they are sending messages, they seem to be queuing up and sending all at once (sometimes an hour later) with no indication that there is a problem with the client. Exiting the client and relaunching fixes the issue but again, since there’s no errors or indication of a problem, the user doesn’t know to do that.

We haven’t had this issue on Pidgin but then again, the folks that use Pidgin are often on more stable home connections. I’ve tried to replicate the problem myself by getting on the VPN and killing the connection many ways (pulling cable, disabling adapter, killing VPN service) but it always gives me the connection problem error so no luck there.

Do you guys know if there is a potential timeout setting I could tweak or anything like that that could help rememdy this? I’m in the process of building a test environment so I can test upgrade OpenFire but it seems more like a issue with the Spark client anyways. Any help would be incredibly appreciated!


#2

Yes, most probably Spark issue. We had similar problems with Sleep on laptops. After waking Windows up Spark would show as green, but in fact it won’t have connection at that point and usually would start reconnecting only after a minute or so. I don’t have any solution though. I have filed this when we were having such problems https://issues.igniterealtime.org/browse/SPARK-1823
But nobody looked into this. Spark has not active developers for a long time.
For us the workaround was to make Sleep timeout longer.