powered by Jive Software

Spark Manager update failing with 1.1.4

I had originally posted a problem about Spark constantly trying to upgrade users already running the recommended version. Now I have a new problem.

I have put Spark 1.1.4 on my server, and made it the recomended version. Users receive the notification that an update is available, and agree to upgrade. However, nothing happens. According to my users, after clicking “yes” the system looks like it is doung something but after its completed Spark is still 1.1.3.

I’'ve tried using both the offline & online installations for Spark but neither seems to correct it.

Anyone else seeing this problem?

Hi PC,

It sounds like for one reason or another, the new exe that is being downloaded is not being invoked. Can you verify that there is a “spark_1_1_4.exe” in the bin directory of spark? Also, please post any logs you may have in the logs directory.

Cheers,

Derek

Here’'s what I did today:

I re-downloaded the offline installable, stopped my Wildfire service, put the new Spark copy into my resources folder, and restarted the server.

On my personal workstation (I have admin rights) I removed 1.1.4 & installed 1.1.3. I instructed my system to check for an update. It was found, and it installed successfully.

I had two users try the update as well. One of them I know has admin rights,the other does not. Both failed. I had them check their Spark “bin” directories. Nothing was there.

Somthing I noticed though:

I have port 9090 blocked on my firewall. It was my understanding that was the Administrative port. I have it set so only my conputer can communicate with the server on that port.

Did I accidentally shoot myself in the foot with that layer of protection?

It looks like that was in fact it.

I rewrote my firewall rull so all computers can connect to port 9090 & had someone try to perform an update: it worked.

I could just be over paranoid ( ), but maybe the update port should be a different one from the admin port? Just my .02.

Thanks for the help!

Hi,

you could also use Apache + mod_proxy and proxy only the update URL. It should be something like /updater or /sparkmanager ?

LG