Spark not indicating on recieved broadcast message


We’re having a problem with Spark that we haven’t been able to resolve ourselves and thus though we would ask if anyone here knows what might be causing it.

As the title says, when we do broadcasts there is no indication on the recipients that they have recieved a message. They get the message so there is no issue there, although some cliens sometimes get blank messages but that’s a separate issue.

We are using Spark 2.6.3 and Openfire 3.6.4


I have the same problem … and I (actually “we”, my co-workers and I) REALLY need to know how to resolve this thing … please ?

Do you mean that chat window is not flashing when a user receives a broadcast? How are you sending broadcasts, using Spark or from the Admin Console?

The messages are sent using Spark.

Neither the chat window or the icon in the notification area indicates that there is a new message.

Can’t reproduce this with Spark 2.6.3. If i send a broadcast in Spark to other Spark users ( i select them in the Broadcast window), then they get a new message window and a popup about a new message (if popups are enabled), also the new message window is flashing. Tested on Windows XP/Win7 32 bit.

I’m using Win7 64bit … maybe this is it ?

I can only confirm, that chat window is not flashing on 64 bit (i guess flashing dll has to be compiled for 64 bit), but i do get a new window when receiving a broadcast message. SPARK-1414

We only get a new tab in Spark, when receiving a broadcast message (as the previous version of Spark). But nothing indicates it =/
Is there a solution for the compilation in 64 bit of the flashing dll ? Maybe I can use the dll version of the previous Spark (strange manipulation but sometimes it’s possible) ?

We send from a mixture of Win7 64bit and XP 32bit machines but all recieving machines are XP 32bit.

If you can’t reproduce it I guess we’re stuck for the time being. Is there anything I can do to help at this stage?

Maybe I am lost, but the 64bit flashing window dll I made was included in builds after 12164. You can see my post here: FlashWindow.dll

I did modify my build to go back to the normal windowed mode for broadcasts instead of an alert window. Maybe this is why it works for me?

Hi George,

we are preparing 2.6.4 or actually it is going to be 2.7.0 (since we move to Java 7). Can you provide a revised flashwindow.dll to be included in 2.7.0 beta?

There are tons of reports regarding w7x64 flashing issues (no compilation at hand right now for me). If you can assist us with flashing, I’ll review the w7x64 reports.


Sorry, been out of the loop for a while. Has there been any update to the source for the 32 bit version? All I did was re-compile the existing code into a 64bit dll. It should work exactally the same as the 32bit version. If the code has changed can you point me to the updated source?

I will check it out sometime next week. I don’t have visual studio at home.

I have re-compiled the dll using Java 7 for 64bit Windows.FlashWindow.dll

I installed this on my current Win7 64bit systems with the latest svn and did not have any problems with broadcasts or normal messages. Then again I wasn’t having any problems before either.

This issue is resolved for us now. What we did was go back to Spark 2.58 but this time we used the version with Java embedded and the broadcasts are back. Our other issues with Spark preventing the machine from shutting down, , has also been resolved by using this version of Spark.

I can’t say if these issues are down to Spark, Java or our MSI packages of them but I’m just happy everything works now.

I’ve tried to reproduce this issue with WinXP 32bit to Win7 64bit and the current DLL, but everything works fine.

Any idea for reproduce this error?

Not really no. The only thing I can think of would be some weird permission problem as our users are users on the machines as well but that feels weak. Other than that I’m afraid that I can’t offer anything more substantial than that Spark with baked in Java was our saviour.