powered by Jive Software

Spark not starting with the system

Hi everybody

I compiled the spark and I created one installer with inno setup, but when the operating system make logging the spark don´t start together, I am using jre-6u27-windows-i586-s and the trunk that I´ve did download from svn 12885

Do you mean that if you go to Spark > Preferences > Login and check the Launch on startup, Spark is not starting for this user on next system startup? Which OS? Or do you want installer to add that registry entry? Then this is up to installer to do this and i can’t help about doing this with Inno Setup. I know that official installer does add such registry entry. You can try adding the same entry with the Inno Setup, that’s for Windows:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]

“Spark”=“C:\Program Files\Spark\Spark.exe”

Yes is checked in preferences all the necessary options, and the Inno Setup also have a policy for creating a registry key, and after installation I checked and created. after his post was to check and switch was no longer there will be some bug in java?

I´ve tried many things here, but after checked for startup with the system, the Spark.exe doesn´t write in the registry, I did one compare with my setup and with the oficial setup.

Any idea in how to fix it ?

Do you mean that the official installer doesn’t add that registry either? Maybe this is related to your system. What OS you are and is it localized? Maybe it’s Brasilian? Maybe you have different registry names for this. Or maybe this is related to your regional settings. Or maybe your user doesn’t have rights to write into that registry, which is weird.

Hi,

just a comment: You may not want to use a JRE above u23 since it breaks the automatic closing of Spark, if windows is shut down. I can’t comment, if this is related to your bug report.

Walter

No, the official installer works fine for me in any environment that I am testing, yesterday after my last post I did this test: I did download the install4j and did my own installer with install4j, and worked fine, so I concluded that the problem is with the Inno Setup

Here is a copy of my config file http://pastebin.com/3M0snWFj

hmm, yeah, I have this problem too, this I don´t knowed.

But one thing that I see is that if I install (with the setup that I created) and don´t run the spark after the installation, and look in Windows registry, I can see the config for run Spark with the windows start.

Then I runs the Spark and the Windows registry config disappears

Usually that registry entry disappears when you run Spark if you have it “Launch on startup” disalbled in your settings. Installer creates registry entry, but Spark upon launch checks your Spark preferences and removes that entry if you have this option disabled. It shouldn’t remove that if you have this option enabled. Don’t know why it removes it for you.

I was able to customize the Package with a different name and there are 2 issue.

one when i go to preferences and select launch on startup it writes the registry value as below;

C:\Program Files (x86)\Talk.\Talk.exe i cant find why its adding an extra “.” in the path? Any advice

Also haveing some issues when someone clicks logout it gives and connection error and starter.exe doesnt kick in

Any help? Thanks in advance