powered by Jive Software

Spark not Updating

Is anyone else having a problem using the Spark Manager to update their Spark Client?

I’'m using Spark Manager 1.0.1 and Wildfire 2.4.0 and clients using Spark 1.0.1 get notified there is a new version of Spark available, but when they click OK to install now, nothing happens.

Any ideas?

Thanks----

You’‘re doing better than me, I don’‘t even get a notification that there’'s an update:

http://www.jivesoftware.org/community/message.jspa?messageID=109141#109141

Hi all,

The spark manager for wildfire was not working properly at all. Please download the latest spark manager from the download center again. I do apologize for the inconvenience.

Cheers,

Derek

Hi,

Trying to get this to work aswell. I dont get the auto notification either on login, however the ‘‘Check for updates’’ under the ‘‘help’’ menu does detect the available newer version on the wildfire server, and prompt to download.

To help shadowdog I did his problem when after checking for updates and clicking to download the available client, it was also did nothing. Found the issue to be a server setting. Check under system properties for the ‘‘Spark.client.downloadURL’’. Mine was set to 127.0.0.1 after setting it to the qualified server name it would download. Hope that helps, but I’‘d still need to find an answer to the auto-notification (i’'ll post under the other thread).

Thanks

Hi NASRRV,

Spark is set to check for a new update once a week, so if you wait long enough, you will be prompted for an update. As for the downloadURL being set to 127.0.0.1, that is a bug that needs to be addressed. I will get that fixed for the 1.0.2 release of the Spark Manager.

Cheers,

Derek

Hi,

I have also a problem with Spark Manager plugin, I use Spark Manager 1.0.1 and Jive Messenger 2.3.0 (Jive Live Assistant). If I check for a new version I am asked for the update, but nothing happened. The update your is correct.

Any idea?

Bernd

Once a week? Ahhhh, that’'s most likely my problem then, I was expecting it to just check on startup.

Is there any way to make[/i] it check on startup?

Hi ifao,

Is the url https? There was a bug filed in the 1.0.1 version of Spark that an update would fail if the url was an https. Could this be it?

Cheers,

Derek

Hi unit3,

At the moment, the once a week is hard coded. However, I could maybe add this as a preference in the 1.1 release. Anyone have any opinions on this?

Cheers,

Derek

I’'d definitely love to see it as a preference for 1.1, and if you can set that preference on install, so much the better for me.

In fact, since there’‘s some plan to have install-time configuration for 1.1, it’‘d be nice to have the options for that available in Spark Manager at the same time. I can do the initial push via our Active Directory infrastructure, but I’'d like to have it so people who use the download links or people who get automatic updates get the right preferences as well.

Hey,

Thanks for the reply. Sorry for the delay didn’'t have much time to check the forum this morning.

I checked my server properties and my spark.client.downloadURL is set to “https://jive.mo.mydomain.com:9091/plugins/sparkmanager/getspark”. Changed it from secure to normal (ie. “http://jive.mo.mydomain.com:9090/plugins/sparkmanager/getspark”) and the client updated correctly. Thanks for the help, maybe they will get secure working.

Thanks again -