powered by Jive Software

Spark on the internet

I would put the openfire / spark to run the Internet for access by third parties, I have fixed IP and I did the release of the port 5222, but not the spark or the sparkweb work, like a tutorial for windows.

There is too little information you specify about your network setup. We need more details. Is there a router on the way to your server? Is there a firewall also and have you alowed access to you server in the firewall? Also, how are this “third party” trying to login? What do they put in the Server field? they can try putting the IP address of your router if your server’s name is not in the DNS.

Well I have my server connected to a router / firewall with a rule of release of entry to the port 5222 and 7070 in the field sparkweb put my server ip fixed internet. In my internal network accessing the sparkweb work through my ip internet, odd, but not out!

Users on the outside should use your external IP (of your router) to login to your server.

They use the ip of my router, 201.xxx.xxx.xxx, which contains a rule to redirect to port 52222 and 7070.

They can try adding your server’s name in the Server field and then go to Advanced settings and set the host to 201...*.

Not understand what you mean, put the name of my server? I have a dns on the internet for it, I have other applications that work only with the ip address, the settings are in advanced OpenFire?

If you have a dns record for your server’s name, then they should be able to login using your server’s name. I mean in Spark on the login screen put your Openfire server’s name in the Server field.

What i meant about the Advanced settings. In Spark on the login screen hit Advanced button and uncheck “Automatically discover host and port” and put your router’s IP here. You only need to do this if they cant normally login by only using your server’s name.

If those advises won’t help, then i can’t help you anymore.