Spark (post 2.5.8 through 2.7 Beta) not handling DNS SRV

I can see this is still not working.

Also tried that workaround with no success.

Cannot use SRV records for the domain name or hostname and login to the server. Works on 2.5.8. Not sure the issues with SMACK-225 are equal, since this is still an issue with even ONE SRV entry (one client on server entry, server is Openfire 3.6.4).

Does not work via IP address either. Can login fine with other IM clients (i.e. Pidgin). The logs (SMACK debug)

I think a JIRA is warranted. I am assuming this would be posted to SMACK project?

Does anyone know of a workaround or reason why a JIRA should not be opened? Any comments or suggestions to make this work?

Tony, there are opened tickets and patches posted for both SMACK and OPENFIRE

Please check:

SPARK-751, SMACK-344, OF-477

The patch I posted for openfire (OF-477) has been discussed but it didn’t get in yet…

The patch I posted for SMACK, I remember that it was recommended to be in, but I don’t know if it really got in SMACK (SPARK-751/SMACK-344 is still in progress)

AFAIK, Spark 2.5.8 is not using SASL DIGEST-MD5 as auth layer, and that is why is working, it uses PLAIN-SASL or XEP-0078: Non-SASL auth layer


Come and see me at CoLab @ CSU in March (5th & 6th)

Thanks. I read all of those issues, but there seems to be no movement towrads applying any of these (i.e, they are not being committed, but no reasons are given, nor are they being made available for testing).