powered by Jive Software

Spark rede externa

Oi Vinicius,

Então, verifiquei no site, e realmente as portas estão abertas, todas elas a 5222, 5223, 7777.

Ao logar no Spark via web, eu digito o usuário no programa, a senha, e logo abaixo, meu ip de internet, é isso mesmo?

Mesmo assim, não abre.

Abraços

Amigo, então, para logar no Sparkweb, as portas são diferentes, tem de liberar a porta 80, 8080, estas ai foram para o cliente do Spark.

Vinicius

Me expressei mal, é através do cliente do Spark mesmo que eu tento logar, não é pelo browser não.

Abraços

Amigo, então vamos lá:

A - Sede aonde esta o servidor openfire com o link de internet ip fixo onde estão liberadas as portas

B - Sede aonde tem a estação com o cliente spark instalado tentando conectar no servidor da sede A.

Faça um teste assim:

B - Estação local, abra o cmd, telnet:

open xxx.xxx.xxx.xxx (onde sera o ip do local A) xx (onde sera a porta)

Veja se conecta, se tua estação é Winxp o telnet é padrão do windows, se for Win7, terá que ir pelo painel de controle, programas e recursos, vai em ativar ou desativar componentes do windows, e ativa o telnet.

Poste se conseguiu conectar nas portas.

Oi Vinicius,

Não conectou em nenhuma porta não…

Tentei nas 3, na 5223, 5222, 7777.

Eu uso win7, eu ativei o telnet lá por onde vc falou.

Tem algo bloqueando pelo servidor será? o firewall dele está desativado já, e ainda por via das dúvidas, eu adicionei o Spark e o Openfire no firewall como liberado.

Amigo, seu servidor openfire tem algum antivirus instalado?

Estranho responder as portas, responde o ip, mas não conectar, como você coloco no modem:

A

TCP 5223 ip interno servidor openfire

TCP 5222 ip interno servidor openfire

TCP 7777 ip interno servidor openfire

B

Cliente Spark

IP externo do local A

tenta ver se o modem aceita adicionar uma DMZ para o ip do servidor openfire.

Em execução não tem nenhum antivirus.

DMZ? Não entendi oq é isso.

No modem está o seguinte:

modem.jpg

Como faço pra adicionar a DMZ pro ip?

Danilo, tem algum lugar no modem perto desse menu, que você pode clicar em adicionar DMZ no ip tal, é uma função do modem, tipo ali aonde você tem em nat ou vitual server.

Por via das duvidas, apaga as portas, adiciona novamente já como TCP/UDP.

Oi Vinicius,

Já fiz isso agora, apaguei e inclui novamente as portas do Spark no modem, como TCP/UDP e também ajustei o DMZ pro ip do servidor openfire.

Tentei acesso pelo programa, ainda não deu.

O Ip q coloco no programa em servidor é o ip da internet q é pego pelo www.meuip.com.br, isso mesmo né?

Danilo, a principio você fez tudo certo, não estou conseguindo imaginar o que poderia estar acontecendo ai, no programa do Spark em sua estação que não fica no mesmo local fisico que o servidor openfire, que essa segunda localização tem outra internet, outro ip, você coloca o ip externo que pode ser o ip que pegou pelo site meuip.

Caso queira, posso lhe acompanhar remotamente nos testes, segue meu skype para melhor comunicação:

suporte.fugacouros

Oi Vinicius

Deu certo, eu estava tentando a conexão externa no servidor, mas estava na mesma rede dele, e aí não funciona.

Tirei meu cabo de rede, e coloquei em uma outra internet q tenho, e deu certinho.

Valeu amigo, e obrigado pela paciência.

Grande abraço.

Danilo

Estou reabrindo esse post porque eu tinha a mesma duvida e abriu muito a minha mente isso, so que no meu caso nao e usando spark, é usando um aplicativo para celular android, chamado ChatSecure…

no caso eu fiz como o Danilo Soares só que lá pede user@domain

como eu faco o login ?

vou citar um exemplo > o meu e hydrasrv.zapto.org (no-ip)

nas configurações eu coloquei Dominio: hydrasrv.zapto.org

meus 2 usuarios sao

titan

s3mini

tem que da certo se eu colocar titan@hydrasrv.zapto.org?

Apenas para registro a configuração do Leonardo esta correta e funcionando, falei com ele e ajudei a testar pelo Face.

Olá Leonardo,

Essa entrada de DNS no no-ip está direto no seu servidor do openfire?

Se sim as portas TCP 5222, 5223 e 7777 estão liberadas ?

Para testar faça um telnet no seu dominio:porta

Galera boa tarde , ja tenho o sistema funcional no interior da empresa , liberei as portas 5222 e 5223 no meu roteador , esta liberada , mas eu não sei qual é o método de preenchimento no campo servidor.

ex eu preenchi o DDNS da empresa http://servidorempresa.com.br

mas não entra não carrega o sistema , alguém poderia me auxiliar? Grato

Bom dia amigo, pode ser várias coisas, primeiro você tem que verificar se as portas realmente ficaram liberadas de fora, pega o seu ip externo direto e consulta de outra rede se quer eu posso fazer o teste com você. Depois tem que verificar como você fez a publicação do seu hotsname, você está usando o no-ip, você tem um apontamento tipo A no registrobr, como você fez a publicação?

Outro problema que da é pelo cliente novo do Spark, você tem que marcar a opção dele de não verificar os certificados. Qualquer coisa pode me chamar no Skype e depois que funcionar nos postamos aqui no forum.

Skype: suporte.fugacouros

Att

Vinícius Roberto Gobbi