powered by Jive Software

Spark Search does not work but server is fine

We are running Openfire v3.8.2 with Windows Active Directory LDAP integration. Our clients are a mix of spark 2.5.8 and 2.6.3. We frequently get the complaint that the search box in Spark doesn’t work. When we try to use it we receive “unable to contact search service”. Now, it use to work though which is the frustrating thing. I have the same experience on my machine, I’ve reimaged my computer for various reasons and I’ve removed spark and reloaded several times with no change.

On my iPhone I can run the IM+ jabber client and the search box on there seems to work fine. I also downloaded and tried Psi as a client just now on my Windows workstation and search worked there as well. In other very old threads regarding search issues I’ve seen folks ask if advanced user search works in the admin console. It does for me. These 3 things lead me to believe the plugin is working great but spark is not. What is strange though is most of us have seen it work from time to time.

Finally, I had a user tell me this morning that spark search works when she gets here early in the morning and there’s only a few folks online. During the day, our user load is probably 150-200 logged on users. In the grand scheme of the IT world, this just doesn’t seem like a lot. And how would that affect spark but not the server? Like I said Psi worked just now, mid day with full load. Spark does not. I was at 2.5.8 this morning when I came in and have upgraded to 2.6.3 since.

Thoughts?

This is what errors.log file shows for spark by the way when attempting a search

Oct 8, 2013 10:00:53 AM org.jivesoftware.spark.util.log.Log error

SEVERE: Unable to load search services.

service-unavailable(503)

at org.jivesoftware.smackx.search.UserSearch.getSearchForm(UserSearch.java:84)

at org.jivesoftware.smackx.search.UserSearchManager.getSearchForm(UserSearchManage r.java:73)

at org.jivesoftware.sparkimpl.search.users.SearchForm.(SearchForm.java:66)

at org.jivesoftware.sparkimpl.search.users.UserSearchForm.showService(UserSearchFo rm.java:260)

at org.jivesoftware.sparkimpl.search.users.UserSearchForm.(UserSearchForm.ja va:97)

at org.jivesoftware.sparkimpl.search.users.UserSearchService.processQuery(UserSear chService.java:76)

at org.jivesoftware.sparkimpl.search.users.UserSearchService.access$200(UserSearch Service.java:41)

at org.jivesoftware.sparkimpl.search.users.UserSearchService$1.finished(UserSearch Service.java:59)

at org.jivesoftware.spark.util.SwingWorker$2$1.run(SwingWorker.java:148)

at java.awt.event.InvocationEvent.dispatch(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

Hi, I too have same issue, when logged in users are less say <10, it works else it shows the same error in spark log as @Curtis McKay mentioned.

Thanks in advacne for the suggested solution.