powered by Jive Software

Spark / SIP Phone's STUN configuration hint needed

Hi community;

I am using Spark 1.5.8 w/SIP Phone plugin 1.0.5 on a OpenFire 3.6.4 platform.

My goal is to perform a Spark SIP REGISTER onto an Asterisk 1.6.2.13 but unfortunately

the Asterisk only sees the LAN IP instead of the public IP, thus the registration

would not work.

I assume this is a STUN problem and I need help on how to correctly set it up, I have tried many things up to now.

(please note that I am able to have Zoiper to register correctly using the same credentials)

Here is what I get on the Asterisk:

Trying to put ‘SIP/2.0 401’ onto UDP socket destined for 142.101.232.76:5060

Here is what I have in the mysql:

mysql> select * from ofSipUser \G;
*************************** 1. row ***************************
username: fred
sipUsername: 186466
sipAuthuser:
sipDisplayName: 5143081595
sipPassword: 692883
sipServer:
stunServer: stun.zoiper.com
stunPort: 3478
useStun: 1
voicemail: *98
enabled: 1
status: RegistrationFailed
outboundproxy:
promptCredentials: 0
1 row in set (0.00 sec)

Please note that I have set stunServer, stunPort and useStun manually as the OpenFire

admin interface would not populate these fields even if the STUN settings are configured/enabled.

I know I have blanked sipAuthuser and that is because I don’t use the **fromuser= **SIP parameter on the Asterisk, anyway.

I also have turned on OpenFire MediaServices but it did not change anything; I would rather

not use it as I don’t want voice traffic to travel through the openfire server.

1- How do we correctly set STUN using a commercial one such as Zoiper

2- When we change openfire sip/media services, do we have to restart anything (services, etc.)?

3- Is it correct to put 1 in the useStun field? Default is 0 so I assumed putting 1 would enabled it.

A hint would then be greatly appreciated at this point!

Cheers

Ok, I finally found the problem, it was the** nat=yes** sip parameter that wasn’t set correctly.

That setting helps Asterisk resolving public IPs.

Cheers

Hello Fred,

Fred a écrit:

(please note that I am able to have Zoiper to register correctly using the same credentials)

please can you tell me how to register zoiper to work with openfire.I use zoiper communicator and i can’t make it work with openfire(zoiper register the xmpp account created on openfire but there is no presence,so we can’t chat).

thank you.

Hi Chaima,

Sorry I never used Zoiper with Openfire…only with Spark.

I only used Zoiper to verify that my Asterisk PBX was correctly configured

before trying a SIP register using Spark.

I was using Spark/Openfire but abandoned all hopes because its too difficult to get support

on these products.

Cheers