powered by Jive Software

Spark startup error issue 2.8.3

ipmsgclip_r_1487661771_0.png

All time PC start then startup program start but spark is not start and some error.

It’s not start …

How can i start spark ???

Check the error and warn logs and post them here.

C:\Users\User\AppData\Roaming\Spark\logs

Plz check & solve ASAP.
errors.log.zip (2031 Bytes)
warn.log.zip (2213 Bytes)

There are no recent errors in the logs. What server do you use and what version (Openfire?)? What is your xmpp domain (as shown on the Admin Console first screen) and servers fqdn name? What do you put as Domain in Spark?

Open fire version: - 4.1.3, Domain : IP & Domain name both tried, facing same issue.

Look at the picture below. That’s the first screen of Admin Console of your Openfire server. somedomain in this example is the Domain. In Spark you should put it into Domain field. Not the somemachine, which is a name of a server you have installed Spark on. If Spark can’t login with somedomain, then you don’t have a proper DNS setup. If you can’t setup a proper DNS entry or don’t know how to do it, you can still put somedomain into Domain field of Spark and then go to Advanced menu on the login screen and put server’s IP into a host field.

domainvsfqdn.png

I am able to login in spark but need to login manually.

It’s not start automatically on pc startup.

Please provide me proper solution.

Thanks.

Go to File > Preferences > Login and enable both Auto login and Launch on startup.

yes, I already try this solution but it’s not proper solution.

I don’t understand what is proper solution for you.

You give me (Go to File > Preferences > Login and enable both Auto login and Launch on startup.) this solution.

I told you i have already try this solution.

But still same issue.

So, I hope you understand & give me best proper solution.

Thanks.

Lalit Suthar wrote:

I am able to login in spark but need to login manually.

It’s not start automatically on pc startup.

Please provide me proper solution.

Thanks.

Last question was about Spark not starting automatically on Windows startup. So i told you how to enable that option. Is the issue still that Spark doesn’t start on startup or the connection problem as described in the first message?

Spark start automatically on windows startup.

but its not login automatically, error screen appear then need to wait for 1 min then need to login manually then after spark start.

please help me to out for this issue.

i think openfire taking time at startup so facing this type of issue.

Why do you say Openfire is taking long to startup? Are you running Openfire on the same machine?

Yes, It’s same machine.

Well, you should have provided this info in the first message… That’s normal. Openfire takes longer to start and Spark starts faster and can’t find a server. There is no solution for this. Running Openfire on a user system is not a good idea and one should better use a server OS and a separate machine for a server application. So you either should always run Spark manually (waiting a few minutes for Openfire to start) or maybe you can create a task scheduler script to run Spark on system startup with a delay. But i won’t help with that. Look on the Internet for startup scripts ideas.

Before i am thinking issue of openfire delay startup but its not after startup perfectly, facing same issue with spark startup. please suggest me solution for that.

Thanks.

How long does it take for Openfire to startup after the system start? Is you Openfire installed as a service?

System start after Openfire startup within 2 minutes.

Yes, Openfire installed as a service.

Thank you…

This doesn’t seem to be out of norm. I have timed how long my server starts, but i think it is close. Windows has a lots of other services, that should startup first. So it is launching them in stages. Openfire is just somewhere in the lower part of the queue.