powered by Jive Software

Spark Timezone Settings

Sometimes Spark picks the wrong timezone, the reason is not known and may be a JVM or a Spark problem. The timezone can be changed by “-Duser.timezone=Canada/Mountain”, “-Duser.timezone=GMT-8:00” or similar settings.

See Spark JVM Settings for a general description how to add Java System Properties to Spark.

hello.

The problem was with windows 7 In windows XP or windows 8 I had no problem.

After several research and attempt to resolve the issue with this option solved my problem.

I just created a file with the name spark.vmoptions -Duser.timezone = GMT-2 line: 00 in the same directory as the exe is spark.

What I noticed in windows 7 in definisão the windows timezone is “UTC-03: 00) Brasilia”. If you change the windows to (UTC -02: 00) Coordinated Universal Time-02, which is not the standard of our time zone, also works without the need to create the file in spark. More in openfire server, “Server / Language and Time Zone” does not have the “UTC-03: 00) Brasilia” option. Just the “GMT-02: 00” option. I do not know which spark catches, most believe that if he had to “UTC-03: 00) Brasilia” option in openfire solve.

Longer leave the set spark.vmoptions file correctly solves the problem.

Antonio