powered by Jive Software

Spark user unable to see reply messages but can send messages

Openfire 3.6.4 on Linux OS

Spark Client 2.6.3 on vairous Windows versions

The Spark user can send me a message but when I reply they do not ever see my messages. The user was working fine until we had to shutdown the Spark server and bring it back up, this is when this specific issue started happening and this is the only user reporting the issue. I had the user login to my personal machine where Spark works fine and we encountered the same issue when sending a message to another user and we cannot see their replies back. Which leads me to believe it may be a issue with the users Spark account. We currently though use LDAP account method and do not manually create accounts on the server. I have tried deleting the local Spark user folder and that did not help. The user is affected with this issue no matter what Spark Client\machine he logs in from.

Here is a dump from the debugger:

<stream:stream to=“” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

<stream:stream to=“roc-chat01.aafcu.corp” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>

am9zZXBoZABqb3NlcGhkAHZveFJ1bXBvbGUtMT M=

<stream:stream to=“roc-chat01.aafcu.corp” xmlns=“jabber:client” xmlns:stream=“http://etherx.jabber.org/streams” version=“1.0”>


<iq id=“f2SPF-7” from=user2@roc-chat01.aafcu.corp/user2" type=“get”>



<message id=“f2SPF-45” to=“user1@roc-chat01.aafcu.corp” from=user2@roc-chat01.aafcu.corp/user2" type=“chat”>I’ve turned on the debugger in Spark-- traces packets it seems. F7Mpec

This is him adding me as a user:

Mar 15, 2013 3:19:39 PM org.jivesoftware.spark.util.log.Log error

SEVERE: Unable to add new entry user1@roc-chat01.aafcu.corp


            at org.jivesoftware.smack.Roster.createEntry(Roster.java:284)

            at org.jivesoftware.spark.ui.RosterDialog.addEntry(RosterDialog.java:572)

            at org.jivesoftware.spark.ui.RosterDialog$7.construct(RosterDialog.java:442)

            at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:141)

            at java.lang.Thread.run(Unknown Source)

Any ideas?

Rebooting the Spark serve resolved the issue. Nothing else worked but rebooting the server.