Spark Vista

I need to install Spark on Vista but its not compatible

Can you define “Not Compatible”

  • Do you get an error message? If so what is the error?
  • Does it crash on startup with out an error?
  • Has it worked before?
  • What verison of java do you have?

I don’t want to be a jerk, but you’ll get a lot more help quicker if you put a little more into it. Don’t forget, your asking a community of people for free support. It’s really easy for others to ignore a question with no substance.

I’ve been running Spark on Vista for some time now and it’s running perfectly normal.

I also have been running Spark on Vista 64bit for months now.

Let me shed a little light on the situaiton then. I’m running Vista Business SP1, MS Office 2007 Enterprise and a few other various program. No anti-virus at this time.

I’ve downloaded the latest version of Spark and installed it successfully on this machine.

Wheh I try to start it, I get nothign. No hits, no runs, no errors. No entry in the error.log file, no windows with fatal error, nothing. Checking the task manager shows nothing.

So, as far as I can tell, it doesn’t start and it doesn’t error out.


I’ve seen this on a few systems. The main issue I normall see is that permissions don’t get set correctly on the C:\Program Files\Spark folder. Make sure your users (or if in a domain, Domain Users group) has full control to the folder. On first run, it has to complete the install/unpack files. The normal symptom is you click Spark.exe and nothing happens (no processes, etc…).

Hope this helps!


I changed the premissions to ensure that “Users” had full control, I changed the ownership to myself and reran. I’m now getting the following Java Error:

java.lang.NoClassDefFoundError: com/sun/java/util/jar/pack/UnpackerImpl
     at java.util.jar.Pack200.newInstance(Unknown Source)
     at java.util.jar.Pack200.newUnpacker(Unknown Source)
     at org.jivesoftware.launcher.Startup.unpackArchives(
     at org.jivesoftware.launcher.Startup.start(
     at org.jivesoftware.launcher.Startup.main(

Do you have the UAC enabled ? We had to disable it as well.

Here was our exact steps (we deployed with GPO).

  1. Used 2.5.8 MSI

  2. Disabled UAC

  3. Reset folder permissions to “Domain Users” full control

We had a issue on a few machines, we still have not fixed but this worked on 95% of the 150 machines we pushed too…

Hope this helps,


That got it, thanks! It’s working now.

HI All ,

I have strange issue with Spark on Windows vista 64 Bit .Everything works fine expect the sip Phone it just hangs when i try to call the phone is registered but it gets hanged and nothing happens.I have later download the src and run the code it compiled well and then i went to target\build\bin and ran startup.bat and evrything works well even the sipphone too i can make calls outside But now i wanted to know why i have trouble with build of Spark which is the installed and i install siphone don’t work any clues please .



So, probably siphone in the installer isn’t built for 64-bit systems. What about the latest RC2 version?

HI Sir,

Thank you for your Quick responce . I guess you have got it wrong what i’m trying to tell you let me explain again.I have download Spark 2.5.8 and later i did download spark_2_6_0_12193 and now i have downloaded and installed .I open the file spark i get the dailpad and other stuff When i call any number nothing happens and the programme hangs up for a while and and again start working but nothing happens.

I have downloaded the source code of spark 2.5.8 i have followed the instructions how to build the application after the application is built we have target folder so i now go to target/build/bin and run startup.bat and the application run and even the sip phone works i can make calls I hear the ring or even if phone if off or out of coverage areas i hear all the telecom messages ,But once the call is connected i hear nothing and even on other side too.

PC-PC calling also fails on all applications giving the message you might be behind the firewall but that is not true there is no firewall.

Red5 applictions works but its only 1 side which means other party cannot hear me nor see me I can see them and hear them too.

I’m doning lot of home work on your product the reason i’m a big Fan i love it really now i have made a thought to do some project on voip Like Fring your features are similar to fring but Desktop based i see there is a future for such stuff still. Let me know if there is anyway around to make this work .

Thank you



So. It is not working at all for you on x64 Vista. Well, i don’t use sip phone or pc-pc calls. When i tried long time ago, sometimes it was possible to do pc-pc call. Anyway, this feature probably needs a reworking or fixing, or maybe it will be replaced with the Redfire plugin. Can’t suggest anything. Btw, i’m not a developer or owner if this software, just a long time user

Thank you i understand .I was just updating the problems what i have faced with the recent development.We are trying to build voip solution using Openfire its a replacement of many softwares I personally see there is a future with this product .