powered by Jive Software

Spark Web logging out with errors

I have moved to test openfire 3.3.2 and Spark Web now works on my Linux server

BUT …

Whenever I log in and do anything like changing status or trying to send a message i am logged back out.

Error from firefox firebug:

*<html>

<head>

<meta http-equiv=“Content-Type” content=“text/html; charset=ISO-8859-1”/>

<title>Error 404 </title>

</head>

<body>

HTTP ERROR: 404**<pre>Invalid SID.</pre>**

RequestURI=/http-bind/

<small>[Powered by Jetty://|http://jetty.mortbay.org/]

Hope that makes sense to someone.

Cheers

Simon

could you shift+F5 and make certain you have the most recent code? It appears that the most likely culprit is that SparkWeb isn’'t pinging the server to say it is still alive, if we can figure out what action you are taking to get it to stop pinging the server we can figure out where the bug lies.

Sorry you lost me with the Shift+F5, what is that meant to do when you have sprak web open ?

I only installed the Spark Web through the admin console today.

From Openfire web console plugin says 1.0.0.

I have just had a look in logs and found this: ( lots of the that correspond )

2007.06.25 19:33:15 Client provided invalid session: 5b773012.

Cheers

Simon

Anybody any ideas on this one.

Does anyone need more details?

Cheers

Simon

When I upgraded I had the same problem. I removed opnefire and re-installed and now clients can connect. If rpm -e does not succeed (and you are on centos or redhat) uninstall with “yum remove openfire”. I would back up your database and /opt/openfire first.

I have re-downloaded everything and installed from fresh.

Still have the same problem.

I have tried with with http and https, ( see logs below ).

@ldsopenfire01****/spank

2007.07.01 15:38:37 Client provided invalid session: e6e5a201.

2007.07.01 15:41:33 Sample task not run because less then a second has passed since last sample.

2007.07.01 15:42:01 Client provided invalid session: 49633d5f.

2007.07.01 15:42:59 Could not route packet

*****@ldsopenfire01.*******/spank

2007.07.01 15:43:02 Client provided invalid session: 7dfb2fda.

I cant think whats else I can do to make this work.

I a running on Centos, have downloaded latest and run on windows which works fine.

I have tried changing the port to 8081 also tried on ie7 and firefox.

I also thought it might have been because I had change the security settings so only secure connection for cleints, but also changed that to optional and still no change.

Have tried all these changes with restarts as well.

Cheers

Simon

Message was edited by: simonuk1

Thanks to Alex Wenckus for this work around.

Looks like the client is being logged off because of the polling that isnt working.

Work around is:

Goto the openfire admin console->System Properties add a new property: xmpp.httpbind.client.requests.polling set the value to 0

Cheers

Simon