Spark Webchat Issue

Hi all

I would really appreciate help with making the Spark Webchat work proparly. The following is what I have done:

1.) Running Openfire and Spark Clients on a Windows 2003 Server using Apache and Tomcat Apache servers. Communication between server and Spark Clients working fine;

2.) Fasthpath Service and Spark Faspath webchat plugins installed;

3.) Workgroups set up and users assigned;

4.) Fastpath link on the Spark Client show visible and user logged in

5.) Port 5222 opened on firewall

6.) Clicking on the Fastpath tab…

6.) Copied and pasted the text (script) in a new html file;

7.) Clicking on the Fastpath tab (in the admin console) then on tools tab, opens (URL: showing the following information (please see attached). Although it show offline now on this print screen…when showing only…I can click and communicate with the Spark Clients no problem at all…


a.) I am not sure what the URL should be to jivelive.jsp in the HTML Code snippet. Openfire was installed on the server in the default C:\Program Files\Openfire directory

b.) I have tried accessing the file using URL: (doesn’t work);

Please could someone assist me with this?

Your help is appreciated


I am not sure what your question is. The URL for your Spark Fastpath Webchat is The link for each individual Fatspath Webchat can be gotten from the individual buttons on the page.

If you are looking for a standard web client for openfire, you can use this Just get the 0.9 zip file.

Thanks for your quick reply and link to sparkweb, I appreciate it. Just the following:

a.) What I thought possible is that each individual button will appear on the webpage…showing offline/online (department of course) on which clients may click…

Inserting this HTML code snippet in my HTML file (taking technical department as an example):

<!-- Insert this snippet where you would like the Chat button image to show up -->

<script language=“JavaScript” type=“text/javascript” src=“url to jivelive.jsp”></script>


<!-- End Of Spark Fastpath Snippet -->

I am assuming that the chatbutton offline or online, if a technical consultant is available should appear on the website. No button is placed on the website (html) if configured to the following:

<!-- Insert this snippet where you would like the Chat button image to show up -->

<script language=“JavaScript” type=“text/javascript” src=“”></script>


<!-- End Of Spark Fastpath Snippet -->

But this is what appears if the URL is executed directly in the web browser (just showing part of the output (see attachment).


1.) How do I place and individual button of every department on the website or in the html file?

2.) Related to this, where is the jivelive.jsp located…something is not functioning proparly…?

3.) I have configured port 5222 for Spark Fastpath webchat…why does it access the options via port 9090?

Thanks so much…I really do appreciate your help with this.


Failed to mention:

I see that the jivelive.jsp file is located in the plugins folder of Openfire…but I thought is is not necessary to insert plugin in the URL, is it?



Just realized that the webchat plugin was not installed…it is a webchat.war file…So I couldn’t install it…I am sure this is needed to make this work? How do I install this .war file to Openfire Admin Console?



The war file can be installed in the plugins directory, via the available plugins tab. It can also be directly downloaded from the downloads page and installed in your Tomcat server.