powered by Jive Software

Spark with jre 1.3.0

Hello Everybody

I have to setup a IM solution with Openfire, Spark and Fastpath plugin. I have try with Spark 2.5.8 using jre 1.5 and 1.6 and works fine. The trouble is: the computers have a special app that need jre.1.3 and don’t admit any other jre in the same machine.

Spark 2.5.8 works fine with fastpath plugin.

I don’t know if there is a way to use sparkweb with fastplugin integration or another client. Or a way to use spark with jre1.3

Thanks

what we do is embed java inside our spark install so it uses whatever version I deploy with spark. we do this for the same reason, we have other apps with a higher priority that do not play nice with newer versions of java. I will have to check when I get in to work, but I think spark defines it in the spark.properties file inside the spark program directory. An easy way to figure it out is to install spark on a machine without java, when you start it up it will prompt for the location of java, what you specify gets put in that folder. so if you can edit your msi then you can go ahead and have it prebuilt to use the java in its dir.

I will check the file when I get to work so I can let you know for sure.

I try on a virtual machine installing on XP a fresh Spark 2.5.8 and jre1.3 and list all installed apps and applications. Spark use a internal jre (well, when you create a installer choose and use a jre) so it works.

So now I’m going to try on the real machines and see what happend on normal time.