powered by Jive Software

Spark wont connect to server

Hello,

i’ve setup openfire and everything is working pretty smothly…

some ppl use Ichat to connect to it and it’s working flawlessly…

though those which i’ve advised to use SPARK (2007) have the following problems:

  1. User cannot sign it automaticaly. he has to get into advanced uncheck/check the automaticaly scan for ports option or he cannot sign in.

  2. once signed in. jabber account works fine, though using the IM gateway users keep sigining in and out … and chatting to others doesnt always work.

any help with these issues?

Spark 2007? Do you mean 2.5.8 version?

What do your users put into Server field on the login screen? Is it server’s name or IP address? Usually you should use Advanced > Discover ports and host manually, if your server’s name is not automatically resolvable on a network. So then you put server’s name in the Server field and then uncheck that option and specify server’s IP or resolvable host name.

yes exactly, that version for mac… its the only one available actually…

and the problem happened with me personaly today…

i’ve used to solve it before like you explained but today i couldnt… even though i could immediatly connect with ichat.

username: roland

server: 192.168.1.5

pass

and in advanced options, i removed the automaticaly discover check mark and filled the relevant fields myself

192.168.1.5

port left as default…

i tried both combinations… with or without auto discover and i couldnt connect even though trying different clients such as ichat and pidgin worked perfectly…

in windows it never happens, it only happens on some of the MAC users whether it’s an IMAC or a macbook its irrelevant…

and the weird thing is, i thought at first its a connectivity prob to the server… so i’ve issued a tcpdump on the server

and no request from my client has been made… it simply doesnt go to the server.

so i thought it’s a firewall issue. ive tried to telnet 192.168.1.5 5222 and i connect normaly, obviously … since i alraedy tried with ichat and pidgin…

any idea why is this happening? i realy like spark and it’s plugins especialy the msn plugin…

if i dont find any solution soon i’ll have to ditch spark and move to another jabber client…

Well, 2.5.8 is old, but i dont know is it possible to try something new on a Mac. Can’t help with Macs much. Not using, dont know much about Mac version of Spark.

What is the name of your server? What have you specified in a setup process? Or is it IP address instead of the name? If it’s say “tiger”. Then you should put tiger in a Server field. And in discovery you should put 192.168.1.5 in a host field. This probably won’t help in your case, but that’s the right way to use this option.