powered by Jive Software

SparkWeb Authentication

I am been attempting to setup SparkWeb on my internal Openfire server for several days now. The Openfire/Spark setup works flawlessly and my users are very happy. However, when I attempt to login via Sparkweb outside of my firewall, as a normal user, I get this message: “Not Authorized. Please try again.” The only users allowed to login are Openfire administrators. I have opened the ports on my firewall and configured the client index.html file as suggested in the forums and it works…kinda. Am I missing something in the config?


Openfire 3.6.0a

Spark 2.5.8

SparkWeb 0.9.0

I feel your pain. I struggled for 2 days trying to get SparkWeb to work even without a firewall.

I had the same error, but it was with every username/password attempt.

It sounds like it may be only finding the admin account??

Here’s what worked for me:

I edited the SparkWeb.html file with the following settings:

function jive_sparkweb_getConfig()
return {
server: “my.domain.com”,
connectionType: “http”,
port: “7070”,

bindPath: “/http-bind/”,

autologin: “false”,


I have heard of people getting it to work right out of the box, even with the connectionType = socket and port = 5222.

Let’s hear more…

Thanks for your help. Do you know where I can get the “assets/css/SparkWebSkin.swf” file? I have basically started over with the sparkweb client config, but now I cannot remember where I got this file from.


It’s funny you should ask that, simply because I have rear several posts about the need for that file.

It seems that was from an old version of SparkWeb. I don’t have that .swf file, nor did I create one.

Don’t need it for ver 0.9.0.

If you really want it, http://www.igniterealtime.org/fisheye/viewrep/svn-org/sparkweb traverse the file structures and you should find it.

Go to the Download tab to get the 0.9.0 software.


Ok, to correct the issue, I just copied SparkWeb.swf to assets/css/SparkWebSkin.swf. This allowed me to login.

Thanks again for the help!

More information for those who are interested. I have tested this on several machines, with the same results. I get the following error attempting to login a second time using Mozilla 3.0.1: “Problem authenticating with the server or you are not authorized to perform this operation”.

However, this login works consistently with IE 7 ( on the same machine) and Mozilla 2 (on a different machine). Must be some setting or maybe related to changes between Mozilla 2 and Mozilla 3. Again, I can usuall login in the morning without error, when I logout and attempt to login again I get this error.

Hope this will help track down this intermittent error.


Thanks for your response, but I am running SparkWeb 0.9.0. Maybe I am misisng something else. Just to be safe, I will wipe out the file and config and start over with a fresh download.



Hi Friends,

I done with ur all instrictions it wont work. can help on that from where i will get SparkWebSkin.swf file. Please help out from this.