Sparkweb install problem - can''t access java compiler

I just installed Sparkweb with Wildfire 3.2 for evaluation. When I tried to access it using web browser, I got an error. Basically the application server couldn’'t find the java compiler to compile the jsp files. I have JDK1.4.2 installed on my machine and can access the compiler from the cmd box. How do I make the JDK accessible to Sparkweb?

Thanks & Regards,


I had exactly the same problem. I resolved it by downloading and installing the 1.6 JDK and setting the JAVA_HOME environment variable to point to the JDK (eg. C:\Program Files\Java\jdk1.6.0 ) and adding %JAVA_HOME%\Bin to my path.

I’'m not sure which particular step solved the problem but it worked for me

Hope this helps,


Thanks very much Stuart, it worked! My guess is that it doesn’'t like older versions of JDK.



I am seeing the same exact error:

java.lang.IllegalStateException: No Java compiler available

Running Java 1.5.05 - SparkWeb doesn’'t depend on Java 6 does it?


I’'m not sure Jeff. I downloaded the Windows Wildfire Server 3.2 package with the JRE included. When I saw the compiler error I figured I needed a JDK so just downloaded the latest version (1.6) and set the environment variables that I hoped would allow SparkWeb to find the compiler.

Try setting an environment variable and path to your existing 1.5.05 JDK and see if that fixes it for you. The SparkWeb plugin is still in beta so we’'re bleeding edge here

It maybe a Jetty issue, though, I am not positive. The compile targets are set to 1.5 so as far as I know that shouldn’'t be the issue, but I am looking into this now.



Any word on this? Are other people able to run SparkWeb in Java 5?