SparkWeb On Ignite

Hello All,

We are happy to announce SparkWeb Beta is up on Ignite Feel free to create an account, and would love to try and group our ignite users with one another.



SparkWeb URL:

Hi Derek,

My environment is RHEL5 / Firefox / Flash 9.0 r31 . I can’'t get text to be entered into the boxes. nothing appears to happen.

On WinXP / IE 7 , I get a security error 2048.


yes, I run into the same error:2048, cannot register, why?

i have tried IE6/firefox

thx !


I’d really like to see what this app can do, but can’t seem to find a platform that it works in…



I cant register on Linux/Firefox either.

I can definitely reproduce this issue; I’ll make a note to check into it on Monday.

Hi David,

Have you had a chance to check out the issue? Thanks and sorry for being annoying…


Check out, yes. Fix, not so much. Hopefully pretty soon

I had the same experience yesterday running 3.3.2 and the beta of SparkWeb, I got in once, noticed the differences from the regular 1.x SparkWeb, but then couldn’t login ever again. Existing user, new user, nothing, just that 2048 error message over and over. I fixed it by rolling back to 1.x SparkWeb.


Could you suggest a browser/OS/flash combination that actually works?



We’ve determined what the issue is, so it should be fixed fairly shortly (it’s not fetching the crossdomain file correctly).

sorry to continue to be a bother, but I’m trying to put together a proposal and would like to see how this stacks up against other web based jabber chat clients (jwchat, jeti, etc)

Ironically, I can now enter text into the login box if I do some tricks, but still get the cross domain error.




Hindsight is 20/20 apparently. I’m cranking on fixing ssl http-binding in Openfire and haven’t had time to look into this. Sorry!

crossdomain should be fixed now, but there’s another issue. Looking into it now.

Thanks for continuing to look into this. I am currently getting a server 404 on the page, did it move somewhere?


We ran into some Weird Issues® unrelated to SparkWeb itself. It’ll be back (and hopefully working, since I made the necessary change) as soon as we work it out.

Thanks for getting it working! I was able to get logged in after getting around a plugin focus issue with firefox.

If you find you can’t type in the login box, try clicking on the app or on another application and then click back. I was able to trick it by maximizing and minimizing the FIrebug plugin.


Yeah, the focus issue is nasty. One firefox person describes it as "possibly the worst accessibility bug that we won’t have a good story for in

Firefox 3." ( -access-locationbar-or-switch-tab-using-keyboard.-t4365854.html)

At the moment account creation appears to be broken, but is actually not. The error message is spurious and can be ignored; registration will still work. (I’ve fixed this for b2).