powered by Jive Software

SparkWeb on OpenFire

I am using OpenFire 3.6.4 and it is working quite well for our company. I wanted to try SparkWeb 0.9.0 and see if this would work where we had not yet deployed Spark 2.5.8. I setup OpenFire as fully stand alone.

I read that you that would not need an independent web server and could place SparkWeb in:

\Openfire\plugins\admin\webapp\sparkweb

I downloaded and tried that.

I navigated to:

http://openfireservername:9090/sparkweb/SparkWeb.html

The title shows as “SparkWeb” and I can see the favicon.ico, however, the rest is just blank. I assumed the SparkWeb.swf may have been the issue so I downloaded the most current as well. Still nothing. I have read the many post here about the SparkWeb.html file and what to edit. I still got nothing.

Then for some reason went straight to:

http://openfireservernamet:9090/sparkweb/SparkWeb.swf

It worked! Not sure why the HTML was not working. Guess it would be nice if it did so I could pre-config some things. Not sure why it does not. Thought my experience would be helpful to other new folks to OpenFire and SparkWeb and maybe someone could shed some light on possibly what I missed about properly setting up the HTML file.

Have Fun!

What if you rename SparkWeb.html to index.html or index.php and access http://openfireservername:9090/sparkweb/ ?

Nothing different for the page rendering. However, the URL changes to:

http://openfireservername:9090/sparkweb/;jsessionid=somerandomcode

Again, I can tell it is hitting the page, it is just not fully executing. I see the color change to grey, the favicon displays and the title is correct.

When using the SWF file directly there are a few odditties (in IE, Firefox and Chrome). One is the close button does not work. The other is the dropdown on each user is not scrollable and therefore anything but the first two items is inaccessable.