powered by Jive Software

Sparkweb "Remote server error 502"

Hello,

I’m evaluating Enterprise (3.4.1), and I thought I’d give Sparkweb a try. In Firefox, I try logging in, and for a brief second, the error message attached is displayed. In IE, the page just reloads back to the login screen. I have what I believe are the correct ports open on the firewall, and verified access to them externally. The Spark application works fine.

Any thoughts are appreciated!

Thanks,

Adrian

Are your versions of Openfire and Openfire Enterprise the same - both 3.4.1?

Hello,

Yes, this was Openfire 3.4.1, which then had the Enterprise plugin installed, version 3.4.1.

Thanks!

When you get this error is there any stack trace information that shows up in your Openfire logs?

SparkWeb will try to access Openfire over port 5229. Can you verify that there is nothing that would block this port? Perhaps you could try using Sparkweb on the same machine that Openfire is installed on and see if that works?

Hello,

I checked the error log previously, but this time I checked all the logs, and this showed up in the warn log:

TLS was required by the server and connection was never secured.

Closing connection : org.jivesoftware.openfire.nio.NIOConnection@4cfb1d

MINA Session: (SOCKET, R: /yyy.yyy.yyy.yyy:56872, L: /xxx.xxx.xxx.xxx:5222, S:

0.0.0.0/0.0.0.0:5222)

Sounds like Sparkweb isn’t agreeing to do transport layer security,

which I’ve required on the server (is that the default or not? I’ve

gone through a number of upgrades, and recently set s2s connections to

Required as well… but I don’t remember the initial c2s value…

I have Spark running on the same computer I’m trying to use Sparkweb

on, and the server reports that the connection is using encryption

(closed Lock icon in the session line for my user). So, it would appear there aren’t any connection issues to port 5222 and the certificate I have works with Spark. Also, I can telnet to port 5229 from the same computer and get the XML with the cross-domain policy settings.

If this was a problem with Sparkweb, I would expect to have been able

to find this issue in the forums, as I’m sure other folks would have had this problem. There must be something specific to

my setup that is causing this. I do have a valid, signed certificate and not the original self signed certs.

Let me know what you think.

Thanks!

SparkWeb currently does not work with secured connections. This is something that is planned to be added in the next major release.

thanks,

Scott

Thanks Scott, I’ll look for this in a future version.

Cheers,

Adrian

Do you know of an ETA for support for secure connections?

Also, what about changing the port that SparkWeb attempts to connect to?

Thanks,

Jeremy