SparkWeb wont login

Same problem that I have. The login button just becomes grayed out and nothing else happens.

okay here is what looks like an error in my debug log

2008.09.16 17:17:58 JettyLog: EXCEPTION Unrecognized SSL message, plaintext connection?
at java.lang.Throwable.(
at java.lang.Throwable.(
at ava:465)
at ava:200)
at org.mortbay.jetty.HttpParser.parseNext(
at org.mortbay.jetty.HttpParser.parseAvailable(
at org.mortbay.jetty.HttpConnection.handle(
at org.mortbay.thread.QueuedThreadPool$

Seems to me I am trying to make an SSL connection over a plaintext connection. I suppose it doesn’t like that. I DO want to make an SSL connection as I am required to by the company. Here is my HTML

return {
server: “”,
port: “7443”,

I think my connectiontype and bindpath are wrong. What would be the correct setting for SSL? Any other ideas regardless of how crazy will be welcomed.

Do a search in the forums for SSL/TSL…

From what I can gather, the SparkWeb client does not yet work over SSL.

However, I also recall a post from someone that said they DID get it to work, but I have not gone down that path as I’m only using the thin client.

The biggest drawback to the web client is the lack of POP. You need to have your browser open all day and continually peek at it to see if you have a new message. With Spark, you can force focus and pops to alert you.

Yes, you connection type should be https and your binding should be /https-bind/

I wish you luck

i’m not sure about the requirement to use https-bind. here’s my config, which does work for me:

function jive_sparkweb_getConfig() { return { server: "localhost", bindPath: "/http-bind/", port: "7443", location: window.location.href, connectionType: "https", autologin: "false", policyFileURL: "xmlsocket://localhost:5229" }; } i pulled out all the spaces due to the forum software's insistence on replacing them with nbsp's ;^) this opens an https browser connection to my server and i can log in and use it. so i think it works...

What does the policyfileurl point to exactly?

i believe that’s the only way you can link the connection between sparkweb and the openfire server. it’s the last line on my opening admin page:

All addresses


Flash Cross Domain
Service that allows Flash clients connect to other hostnames and ports.

If it works with http-bind, awesome. I was referencing other posts I saw.

I’ll try those settings on my end and see if I can get it to go over SSL.


Well thanks for the newer config, my error has changed anyway. Inbound closed before receiving peer’s close_notify: possible truncation attack?
at ava:448)
at ava:200)
at org.mortbay.jetty.HttpParser.parseNext(
at org.mortbay.jetty.HttpParser.parseAvailable(
at org.mortbay.jetty.HttpConnection.handle(
at org.mortbay.thread.QueuedThreadPool$
2008.09.17 16:27:43 JettyLog: EOF

I get no messages in my browser anymore it just hangs. I am at a loss.

So i’ll jump in here too

With Openfire 3.5.2 and SparkWeb 0.9.0 it was working without http-bind (socket and 5222 port). After upgrading to Openfire 3.6.0a it gaves me Not Authorized error. I have tried to change to http-bind (default 7070 port). Same result. Yesterday i was told to download newer SparWeb.swf ( So i have tried to put it in my sparweb folder and reverted config to socket connection. Still the same error. Http-bind. The same. I dont need SSL connection, this is all in LAN. So how can i make SparkWeb to work with socket connection? Or do i really need to build SparkWeb from svn or wait for new release? Maybe that swf on isnt new enough?

I’ll just add a second to this as well, ive got the same issue and it happened once i upgraded to 3.6.0a its been working fine up untill that point. Granted I experienced the upgrade database issue that many other did but after the repair it seems everything else is running ok. Anyone have a solution?

Wroot - I have not been able to get SparkWeb to connect EVER with connectionType = socket…

Below I pasted the setting I have (again) that work every time.

I think the key is the connectionType and the bindPath…

Good luck,


I have already tried that config and with the version from the Not working for me. It seems that a big part of users is experiencing that and only a few ones get it working again. Though, it should be working with old socket config too. Daniel said it works fine at Well, it seems we have to wait till next version and revert to 3.5.2. Not me personally. I dont need SparkWeb that much.

i just wanted to report that i’ve had those annoying issues with the “not authorized” warnings. now i just downloaded the sparkweb.swf from igniterealtime as wroot mentiond and it works (with 3.6.0) as it has worked with 3.5.x

so perhaps you guys give it another chance and try a newly downloaded swf :slight_smile:

This swf hasnt changed for a long time. Size is the same. And today i have found that my problems was probably caused by a firewall. With the latest Openfire and Flash plugin changes i now have to open my 5229 port to be able to serve crossdomain.xml file for a flash application (SparkWeb). Though i still get 1 or 2 login errors before i can login successfully. I have edited my How-to for SparkWeb. Hope that will help someone.

The real problem with SparkWeb afai can tell is that there doesn’t seem to be any real documentation about it. Correct me if I am wrong here but my only option to try and get it working is to blindly make changes and cross my fingers. Not exactly the best model.

tjk wrote:

there doesn’t seem to be any real documentation about it.

Yes. This was my main complaint after it was released. But i dont expect someone will give us a real documentation. First developer is no longer working at Jive, and new one… Well, we havent heard a lot from him for some time. So it’s up to us. I’m trying to put together all the information i can find and test. Try my proposed config (socket, xmlsocket for policy, and keeping in mind the firewall issue, and also trying to login few times) and maybe we can find a working config or confirm that there is a bug somewhere.

well that may be… but i haven’t downloaded a new one since the very first release of sparkweb 0.9.0

current size is 653 702 bytes. And it hasnt changed at least for a few weeks.

Hello, -sorry for my english-

I have got a something else problem

I have got Windows Server 2003 StdEd SP1

I have installed WAMP5 1.7.2

I have donwloaded :Openfire 3.6.1

I have donwloaded : SparWeb 0.9.0

I put Sparwek directory into …\openfire\plugIns\admin\webapp\sparkweb

and into …\wamp\www\sparweb

I modified index.htm like this :

*function jive_sparkweb_getConfig()
return {
server: “localhost”,
port: “7070”,
//localtion: window.location.href,
bindPath: “/http-bind/”,
connectionType : “http”,
autologin: “false”,
//username: “admin”,
//password: “passwd”
//policyFileURL: “
//policyFileURL: “xmlsocket://localhost:5229”


All is ok when I open browser in the server. I can connect and chat. But into the server

.::. Login .::.

When I want do it in other place, in my computer for example, I have got only the login screen and nothing else other.

No warnning, no error in the server log.

.::. Create Account .::.

But when I want to acces with this URL and try to create account I have this warnning in the server :




2008.11.18 09:23:02 Closing session due to exception: (SOCKET, R: /, L: /, S:
org.apache.mina.filter.codec.ProtocolDecoderException: java.lang.Exception: Disallowed character (Hexdump: 3C 3F 78 6D 6C 20 76 65 72 73 69 6F 6E 3D 22 31 2E 30 22 3F 3E 3C 66 6C 61 73 68 3A 73 74 72 65 61 6D 20 74 6F 3D 22 76 61 72 2E 69 6E 74 65 67 2E 61 66 6E 6F 72 2E 66 72 22 20 78 6D 6C 6E 73 3D 22 6A 61 62 62 65 72 3A 63 6C 69 65 6E 74 22 20 78 6D 6C 6E 73 3A 66 6C 61 73 68 3D 22 68 74 74 70 3A 2F 2F 77 77 77 2E 6A 61 62 62 65 72 2E 63 6F 6D 2F 73 74 72 65 61 6D 73 2F 66 6C 61 73 68 22 20 76 65 72 73 69 6F 6E 3D 22 31 2E 30 22 20 2F 3E 00)
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF
at$EntryImpl$1.messageReceive d(
at org.apache.mina.filter.executor.ExecutorFilter.processEvent( :239)
at org.apache.mina.filter.executor.ExecutorFilter$
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)
Caused by: java.lang.Exception: Disallowed character
at va:210)
at org.jivesoftware.openfire.nio.XMPPDecoder.doDecode(
at org.apache.mina.filter.codec.CumulativeProtocolDecoder.decode(CumulativeProtoco
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF
… 9 more

Other information :

I have got a problem with caracters. When I type ‘.’ it’s ‘:’ !?

Thank you for your help

see _