SparkWeb wont login

i just wanted to report that i’ve had those annoying issues with the “not authorized” warnings. now i just downloaded the sparkweb.swf from igniterealtime as wroot mentiond and it works (with 3.6.0) as it has worked with 3.5.x

so perhaps you guys give it another chance and try a newly downloaded swf :slight_smile:

This swf hasnt changed for a long time. Size is the same. And today i have found that my problems was probably caused by a firewall. With the latest Openfire and Flash plugin changes i now have to open my 5229 port to be able to serve crossdomain.xml file for a flash application (SparkWeb). Though i still get 1 or 2 login errors before i can login successfully. I have edited my How-to for SparkWeb. Hope that will help someone.

The real problem with SparkWeb afai can tell is that there doesn’t seem to be any real documentation about it. Correct me if I am wrong here but my only option to try and get it working is to blindly make changes and cross my fingers. Not exactly the best model.

tjk wrote:

there doesn’t seem to be any real documentation about it.

Yes. This was my main complaint after it was released. But i dont expect someone will give us a real documentation. First developer is no longer working at Jive, and new one… Well, we havent heard a lot from him for some time. So it’s up to us. I’m trying to put together all the information i can find and test. Try my proposed config (socket, xmlsocket for policy, and keeping in mind the firewall issue, and also trying to login few times) and maybe we can find a working config or confirm that there is a bug somewhere.

well that may be… but i haven’t downloaded a new one since the very first release of sparkweb 0.9.0

current size is 653 702 bytes. And it hasnt changed at least for a few weeks.

Hello, -sorry for my english-

I have got a something else problem

I have got Windows Server 2003 StdEd SP1

I have installed WAMP5 1.7.2

I have donwloaded :Openfire 3.6.1

I have donwloaded : SparWeb 0.9.0

I put Sparwek directory into …\openfire\plugIns\admin\webapp\sparkweb

and into …\wamp\www\sparweb

I modified index.htm like this :

*function jive_sparkweb_getConfig()
return {
server: “localhost”,
port: “7070”,
//localtion: window.location.href,
bindPath: “/http-bind/”,
connectionType : “http”,
autologin: “false”,
//username: “admin”,
//password: “passwd”
//policyFileURL: “
//policyFileURL: “xmlsocket://localhost:5229”


All is ok when I open browser in the server. I can connect and chat. But into the server

.::. Login .::.

When I want do it in other place, in my computer for example, I have got only the login screen and nothing else other.

No warnning, no error in the server log.

.::. Create Account .::.

But when I want to acces with this URL and try to create account I have this warnning in the server :




2008.11.18 09:23:02 Closing session due to exception: (SOCKET, R: /, L: /, S:
org.apache.mina.filter.codec.ProtocolDecoderException: java.lang.Exception: Disallowed character (Hexdump: 3C 3F 78 6D 6C 20 76 65 72 73 69 6F 6E 3D 22 31 2E 30 22 3F 3E 3C 66 6C 61 73 68 3A 73 74 72 65 61 6D 20 74 6F 3D 22 76 61 72 2E 69 6E 74 65 67 2E 61 66 6E 6F 72 2E 66 72 22 20 78 6D 6C 6E 73 3D 22 6A 61 62 62 65 72 3A 63 6C 69 65 6E 74 22 20 78 6D 6C 6E 73 3A 66 6C 61 73 68 3D 22 68 74 74 70 3A 2F 2F 77 77 77 2E 6A 61 62 62 65 72 2E 63 6F 6D 2F 73 74 72 65 61 6D 73 2F 66 6C 61 73 68 22 20 76 65 72 73 69 6F 6E 3D 22 31 2E 30 22 20 2F 3E 00)
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF
at$EntryImpl$1.messageReceive d(
at org.apache.mina.filter.executor.ExecutorFilter.processEvent( :239)
at org.apache.mina.filter.executor.ExecutorFilter$
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$ Source)
at Source)
Caused by: java.lang.Exception: Disallowed character
at va:210)
at org.jivesoftware.openfire.nio.XMPPDecoder.doDecode(
at org.apache.mina.filter.codec.CumulativeProtocolDecoder.decode(CumulativeProtoco
at org.apache.mina.filter.codec.ProtocolCodecFilter.messageReceived(ProtocolCodecF
… 9 more

Other information :

I have got a problem with caracters. When I type ‘.’ it’s ‘:’ !?

Thank you for your help

see _