powered by Jive Software

Spectrum and skype with spark

Hi all,

I am trying to get Skype working with spectrum and spark in Openfire.

I already have one spectrum transport working for Yahoo and all is fine for that, but I cannot get the Skype transport to show up in Spark.

Configuration done so far:

  • Installed spectrum2-backend-skype dbus xvfb and the offical skype client skype-ubuntu-precise_4.2.0.13-1_i386.deb and all dependancies required

  • Created a new transport cfg for skype:

[service]

server_mode = 0

jid=skype.DOMAIN

admin_jid=gojaraadmin@DOMAIN

password=PASSWORD

server=xmpp.DOMAIN

port=7530

backend_host=127.0.0.1

use_proxy=0

users_per_backend=1

backend=/usr/bin/xvfb-run -a -s “-screen 0 10x10x8” -f /tmp/x-skype-gw /usr/bin/spectrum2_skype_backend

[identity]

name=Spectrum Skype Transport

type=skype

[logging]

config=/etc/spectrum2/logging.cfg

backend_config=/etc/spectrum2/backend-logging.cfg

[database]

type=sqlite3

[registration]

enable_public_registration=1

I then started the transport, and enabled it with Openfire GoJara settings, it also shows as a connected external component.

spectrum2_manager skype.DOMAIN start

But thats as far as it gets, there is no icon showing next to the transport, whereas with the Yahoo one I see the Y, and I dont see it as a option to register to within Spark. It seems that the gateway just disconnects.

backend-1.log just shows:

22166: 2014-06-12 10:05:24,093 INFO SkypePlugin: Starting the backend.

Spectrum2.log is attached.

Note: I have removed the FQDN from the logs and config and replaced it with DOMAIN.

Can anyone help as to what I am missing?
spectrum2.log-skype.zip (1191 Bytes)