SSL Problems

I have been trying to get signed certificates working for days now. I have been through every guide I can find with no success. I have generated and imported keys via the command line. I have generated keys and certificates using OpenSSL, I have tried to import them via the admin console but again, I have no success.

I have my own, self signed CA certificate as this is only for internal use on our network.

Is there something I’m missing? Something simple maybe? I have followed the SSL Guide from e.html but still have problems.

When I import via the command line it tells me everything worked. When I login to the admin console I cannot see the certificates.

I have also generated certificates via the admin console, taken the signing request away and signed it with my CA certificate but when I try to import the reply, it fails with the error: An error occured while importing the Certificate Authority reply. Verify that the reply is correct and that it belongs to the correct certificate.

Importing an already existing signed certificate fails with: There was an error one importing private key and signed certificate.

Can somebody please help me with this?