powered by Jive Software

SSO NOT WORKING -- Openfile Openfire 3.4.5 with Spark 2.5.8

Hi,

I had been trying to get SSO working on both 3.4.4 and 3.4.5 and still no luck.

I had follow the instruction carefully but weeks after weeks it’s still not working!

Could someone shed me some light what is went wrong please.

The debug.log from openfire is:-

2008.02.08 17:34:58 SASLAuthentication: Added GSSAPI to mech list

2008.02.08 17:34:58 NIOConnection: startTLS: using c2s

2008.02.08 17:34:59 JettyLog: EXCEPTION

java.io.IOException: An existing connection was forcibly closed by the remote host

at sun.nio.ch.SocketDispatcher.read0(Native Method)

at sun.nio.ch.SocketDispatcher.read(Unknown Source)

at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source)

at sun.nio.ch.IOUtil.read(Unknown Source)

at sun.nio.ch.SocketChannelImpl.read(Unknown Source)

at org.mortbay.io.nio.ChannelEndPoint.fill(ChannelEndPoint.java:128)

at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:282)

at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)

at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)

at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)

2008.02.08 17:34:59 JettyLog: EOF

And the log from Spark is:-

RAW send Package:-

After read so many artical, I support to see some activity on the openfile’s console, (a little box where it say Openfire 3.4.5

Admin console listening at: http://londc02.mydomain.co.uk:9090 https://londc02.mydomain.co.uk:9091

But this is not the case, I had nothing run on that openfire’s console… is something wrong? i also double check my SPN manay time and ther are correct. Is this to do with my certificate?

Could someone shed me some light what went wrong please, my hair start to run out.

Many Thanks

This is certainly a spark issue. Openfire advertised the GSSAPI mechanism (used for SSO) but Spark did not even try it. Make sure your client has a ticket and is configured correctly.

sorry to be pain, what do you mean spark has a ticket and configuration properly? I installed as normall (default instal), only one thing is changed in spark client side it to copy krb5.ini file from the server to the c:\windows folder. (xp)…