Standalone Red5 SIP phone with AsteriskWin32


I’ve tried for a long time (50 hours+) to run the red5phone on the red5 standalone server with AsteriskWin32 but I can’t get it to work.

  1. I have installed red5 and downloaded the red5phone code from the google code page.

  2. I replaced the red.jar file with the one provided.

  3. a) In “red5/webapps/root” I have the sip phone

b) In “red5/webapps/sip” I copied the WEB-INF folder

  1. I can start the red5server but I’m getting problems after this.

When I load the flex phone through index.html, I get these error messages:

SecurityError: Error #2060: Security sandbox violation: ExternalInterface caller file:///C:/BBB/Tools/red5/webapps/root/sip/flex/red5phone.swf cannot access file:///C:/BBB/Tools/red5/webapps/root/sip/flex/index.html.
SecurityError: Error #2148: SWF file file:///C:/BBB/Tools/red5/webapps/root/sip/flex/red5phone.swf cannot access local resource file:///C:/BBB/Tools/red5/webapps/root/sip/flex/config.xml. Only local-with-filesystem and trusted local SWF files may access local resources.

In Eclipse with Flex: When I click the red5phone.swf I get no errors.

I’m able to make a NetConnection Using:

red5: rtmp://localhost/sip

After this I’m lost. My phone appears to do nothing. No matter what username/password/SIP server, I’m unable to do an echo test with AsteriskWin32.

I’ve tried with other phones so I know that AsteriskWin32 is working. Both red5 and AsteriskWin32 are running locally on my Machine (XP SP3)

Am I missing any components or configuration to get this red5 phone working in order to do an echo call with Asterisk?

Any help will be GREATLY appreciated.

Thank you!