powered by Jive Software

Startup oddities

Hi All,

I installed Openfire on my fresh new Centos server and ran into an odd problem.

I followed the install guide here: http://www.igniterealtime.org/builds/openfire/docs/latest/documentation/install- guide.html

After installing the RPM I ran the openfire.sh script mentioned in the guide an ran the installer. However, after reading a post on the forum, I discovered the new RPM installed a service script in /etc/init.d, so I shutdown the script and started up the service.

The problem is when I go back to the admin console, I’'m prompted to run the installer again. However, the installer errors out with a null pointer.

The odd thing is I can still run the script, and when I run the script I’'m not prompted to run the installer.

Any idea how I can rationalize the settings I made running the script so I can use the service in /etc/init.d?

Thanks in advance,

Geoffrey

Hi Geoffrey,

it sounds like a problem to detect OPENFIRE_HOME by the init.d script. It may help to set it in the startup script.

LG

PS: I did post some for the tar.gz installation in http://wiki.igniterealtime.org/display/WILDFIRE/LinuxInstallationGuide / http://wiki.igniterealtime.org/download/attachments/229500/DOC-1000.pdf