Status/presence with LDAP rosters

I think this is logged in JM-379 … maybe … but not quite, IMHO … this thread is NOT about changing the LDAP/AD groups (i.e. who is in what group in the LDAP/AD) and then the rosters that the clients see not updating, but rather the PRESENCE information (the “show” packets) for members those LDAP groups is not being sent to the clients.

Yep, we have the same thing. Under the last release of JIVE and under the current Wildfire release as well. Presence notification does seem to work at first when the server is just started (but that COULD be an illusion) but after a while it certainly does not work. Very frustrating.

I dont’’ think JM-379 relates to this issue. Has anyone openned a bug for this?

We’‘re having the same problem, presence is not updating to clients in shared groups. Our config is ActiveDirectory - LDAP. Only work- around I can find is to log out and log back in. Using WildFire 2.4.0 and the Pandion2.5, also tried others but they’'re not getting updated presence either.

We have a mix of groups shared to all users and a few shared to group members only.

Going to update to 2.4.1 to see if it fixes the problem.

in case its important to fix the bug, we also have 16 pages of groups.

I whittlted my groups down to 1, thinking that may be it, too… but alas… same problem.

How does one “vote” for a bug to be pushed higher in priority?? This is a show stopper IMHO.

There needs to be a bug listed in the bug tracker and then you can vote for it there… this is just the forum. No one has put this in as a bug yet… or at least last I checked.


I was just reading the readme file for the broadcast plugin and it stated that groups are recommended to be in all lowercase. Well this isn’'t the case with AD-LDAP, we tend to camel hump the case and use spaces in the group names. The broadcast plugin is working for us, but…

This led me to just wonder if this isn’'t somehow related to users presence not being updated as they sign-in and sign-out.

Again the config for this bug is: AD-LDAP, shared groups, WildFire 2.4.1, Pandion client 2.5.

Upgraded my server to 2_4_2 this morning, still have the same issue. user status/presence is not getting updated on the client side. Testing with both Pandion2.5 and Spark 1.03. Using shared LDAP groups from AD.


Tested on Windows Server 2003, LDAP from AD, and shared groups(for all users’’ rosters). Results are the same for both OS. On my initial test, set up the server to run as “localhost”. Everything works fine, including immediate updating of presence/status of users in shared groups. Once I changed to an external host name i.e., the shared groups would not update. This is with the same machine, on the same install (just changed Server Properties). This only happens if I use groups from LDAP. Currently I am just making custom groups.

While the problem is not stopping me from rolling Wildfire out, it is my biggest problem with the software.

By the way, thanks for developing this. Allows us to finally get rid of Lotus Notes once and for all.

I think I’'m experiencing the precense-not-updated problem as well…sometimes!

Maybe it’'s associated with users with strange characters in their names?

conny: No, it happens even with simple a-z names

Hey guys,

Are you using Wildfire 2.5.0? Latest version of Wildfire (i.e. 2.5.0) includes an important fix related to shared groups & presence problems. JM-557

As you can see in JM-557 there were two problems (in the particular setup that was used as a test case). One was a misconfiguration where posixMode was not correctly setup. Having the incorrect posixMode generates that users of the same group are not able to see each other (sometimes). And the other problem was a Wildfire bug that was fixed.

Hope that helps.


– Gato

Can anyone confirm that the bug is fixed?

There is a similar environment I tried to run Wildfire 2.5.0 on, presence update still does not work. Please see my comments in Jira: JM-557

The problem seems to have gone away for me since upgrading to 2.5.0. We are still doing early testing with only a few users, have we have not experienced the problem yet.

This is bug apparently.

I’'ve upgraded to 2.5.0 and STILL have the problem. Using GAIM I logon and see the configured groups (set to show in all users rosters) and the group members. But I only see the presence as it was when I sign on, I get no presence updates. I have to sign off and back on in order to get new presence information.

I also see the same behaviour as pre-2.5.0

I upgraded to wildfire 2.5.0. All clients are using spark 1.1.1 I sill have the presence issue with ldap rosters. It’‘s certainly better than previous version. It seems all random. Some day, I see the users online, some day I don’'t.

Thank you,


Hey guys,

Have you checked if the posixMode is correctly configured? If you are using vmware then I would really appreciate a vmware image that I can use to analyze the problem. Otherwise, I will need you to provide me the steps to configure the LDAP integration just like the one you are using.


– Gato