powered by Jive Software

Stderror.log grows exponentialy!

I’m on Openfire 4.2.1 x64 on Windows Server 2008 x64. A few days ago I found out that literally my main hard drive, just lost all space available!!! It’s not a big hard drive, around 70GB drive but it only has the OS (around 30GB), Openfire and a bunch of utilities and almost nothing less!!!
I then found out that inside openfire log folder there was a big log file, around 30GB, eating all my hard drive space!!! At that time I simply stopped openfire service, I wasn’t able to delete the file, and then delete all log files. After another day the same!!! and so on and so on. Today I decided to look inside the log file. The file was not so big, around 300MB, so with that size I was able to look inside of it.

This is just the beginning of the log file, as the rest is filled with the same “couldn’t setup local SOCKS5 proxy on port 7777: Address already in use: JVM_Bind” line until the service was halted.

dez 21, 2017 9:44:21 AM com.sun.jersey.api.core.PackagesResourceConfig init
INFO: Scanning for root resource and provider classes in the packages:
org.jivesoftware.openfire.plugin.servlet
dez 21, 2017 9:44:21 AM com.sun.jersey.server.impl.application.WebApplicationImpl _initiate
INFO: Initiating Jersey application, version 'Jersey: 1.18 11/22/2013 03:05 AM’
dez 21, 2017 9:44:22 AM com.sun.jersey.api.core.PackagesResourceConfig init
INFO: Scanning for root resource and provider classes in the packages:
org.jivesoftware.openfire.plugin
couldn’t setup local SOCKS5 proxy on port 7777: Address already in use: JVM_Bind
couldn’t setup local SOCKS5 proxy on port 7777: Address already in use: JVM_Bind
couldn’t setup local SOCKS5 proxy on port 7777: Address already in use: JVM_Bind
couldn’t setup local SOCKS5 proxy on port 7777: Address already in use: JVM_Bind

Can anyone help me?! I cannot afford to see all the time if that file is growing or not…

Thanks for repoting this. What all plugins do you have enabled? Do you know what is currently listening on port 7777? What’s puzzling me is that I can’t find that error string in the openfire source tree.

This is likely caused by running an older version of the OFMeet plugin. The older version of the plugin would by default try to bind to that port, while it didn’t use the associated functionality. This should be fixed in recent releases. See https://github.com/igniterealtime/ofmeet-openfire-plugin/issues/31 for details.

OFMeet is Openfire Meeting plugin, right? But what do u mean about older version of OFMeet ?? I have all plugins updated to the last version… going to disable that just in case… do I better disable other plugin that usually are related to OFMeet ??