We have a stderror.log that is growing at a crazy rate. I just took over administering the server and the only way i know how to delete log is to reboot the server. I’m new to all of this, how do I prevent the server from creating the log to begin with?


Have you got a solution? I had the same issue. After deleting the log several times I decided to look into the log and discovered there were errors regarding roster groups that had been imported into OpenFire from Active Directory and had since been deleted from Active Directory. These groups did not appear in the Openfire Groups. However there were rules left behind in the Server Settings->Packet Filter Rules. After deleting the old rules the log stopped appearing.

Hope that helps.



It worked for me

I do not see Packet Filter Rules under Server Settings, in fact, I do not see this anywhere.

I am running openfire 3.9.1.

Can you check, whether “Packet Filter” plug in is installed? if not then there might be another issue.

Thank you for the information Jignesh. I did install the plugin and there were no entries in it.

After digging around I stopped the openfire service, deleted the stderror.log, restarted the openfire service and immediately copied the stderror.log file to my desktop so I could open it. It was growing so fast that it would consume all the free space on the c drive and I could not open it due to its size.

I did notice in the log file that ldap.debugEnabled was set to true. I changed this to false, stopped the openfire service, deleted the stderror.log file and after restarting the openfire service, the stderror.log file did not come back!

So the reason the stderror.log file was growing so quickly and out of control was because the ldap debugging was on.

Hope this helps others out there, as I have been searching for awhile and have not found the answer to why mine was growing.



Thanks you, in future this might be helpful to me too…