powered by Jive Software

Still in set-up wizard with no connection to mysql

Hello folks,

System stats:

linux 2.6.20,

java: jdk1.6.0

mysql: 5.0.33

wildfire/openfire: 3.2.2

I’‘m really eager to move from jabberd2 to wildfire/openfire. It has a lot of the features i’'ve been looking for.

I am at the initial install stage. on the 3rd page of the wizard where it asks you for set up info.

So far i have the following :

Domain: jabber (this resolves on my system in /etc/hosts and bind)

admin console port 9090

secure admin console port 9091

Standard Database connection

JDBC Driver Class: com.mysql.jdbc.Driver

Database URL: jdbc:mysql://jabber:3306/openfire

username: root

password: (password here)

Minimum Connections: 5

Maximum Connections: 15

Connection Timeout: 1.0 days

When i hit continue i see “A connection to the database could not be made. View the error message by opening the “/logs/error.log” log file, then go back to fix the problem.”

The error log is here: http://www.feline-soul.com/files/error.log I will leave it there till the issue is resolved.

To see if anything else was blocking 3306 i did a netstat -pant and got:

tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 6250/mysqld

so i know mysqld is up and running (not to mention that everything else that uses it, is running fine)

It seems to be a connection error, but i can connect to the database using mysql and browse the tables, which are empty, but the structure is in place. In other words i can connect with root and the password. I have to figure out how to change the privileges in mysql so that my "jabber’’ user can connect to it instead of root, but for now i just want to get connected.

Any help or pointers would be appreciated. Is my Java version too new?

Thank you.

From your log message:

Access denied for user ‘‘root’’@’‘linux.feline-soul.net’’ (using password: YES)

It seems your authentication is wrong.

Beware that if you can connect with this login account and password on your database server, it does NOT mean that you will be able to do it from your Jabber server. MySQL auth is “host-sensitive”. You have to make sure that the user/password pair is associated with the right hostname in the user table of the mysql database of your MySQL installation.

$ mysql -u root -p mysql

select * from user where User=’‘root’’ and Host=’‘linux.feline-soul.net’’ ;

And check that this entry has an encrypted password. If not, you could update it:

update user set Password=password(’‘YOUR_PASSWORD’’) where User=’‘root’’ and Host=’‘linux.feline-soul.net’’ ;

flush privileges;

If the entry does not exist you will have to create it.

GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,DROP,ALTER,INDEX on

openfire.* TO ‘‘root’’@’‘linux.feline-soul.net’’ IDENTIFIED BY ‘‘YOUR_PASSWORD’’;

But you’'d better create your new ‘‘jabber’’ user for host linux.feline-soul.net in the first place

Hope this helps,

Alex

Thank you Alex. I appreciate the help!

I’‘m getting there. I made sure that the jabber user in mysql had rights to the "localhost’’ host and gave them full access to the ‘‘openfire’’ db.

Now i get a new message:

2007.03.09 19:16:25 [org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:111)] Failed to create new connections on startup. Attempt 0 of 3

java.sql.SQLException: Unknown initial character set index ‘‘192’’ received from server. Initial client character set can be forced via the ‘‘characterEncoding’’ property.

HarrisonF in #mysql found a bug here: http://bugs.mysql.com/bug.php?id=22456 that patches this problem. I’‘ll try that and report my progress. I’'m surprised no one else has run into this.

Message was edited by: Bearcat

Here’‘s where i am. That bug i just posted still applies to mysql-jdbc 5.0.5 and the bug was filed with 5.03. What gives? Was this just not fixed? No one else is seeing this? I’‘m just talking to myself now and that can’‘t be good. If anyone else wants to join in and make me feel less loopy, that’'d be great.

Message was edited by: Bearcat

Message was edited by: Bearcat

Hi,

I’‘m using version 5.0.4 of the JDBC MySQL connector and I don’'t have this issue. There are always issues with MySQL and UTF8. In order to avoid the problem, besides enabling UTF8 in the configuration file of MysQL, I always use the following options for the JDBC driver configuration (you can update it in wildfire.xml or using the configuration wizard):

jdbc:mysql://localhost:3306/wildfire?useUnicode=tr

ue&characterEncoding=UTF8

I don’'t know if it will solve your issue but it may help.

Alex

Thank you Alex! That did it. Now i have other questions, but i will post them in other threads.

Message was edited by: Bearcat