powered by Jive Software

Strange behavoir with jetty

Hello, i tested the latest master and noticed that jetty was updated from 9.4.35.v20201120 to 9.4.39.v20210325.

But with 9.4.39.v20210325 httpuploads were allways corrupted with error Exception “EARLY EOF”.
I forked the httpfileuplaod plugin and dependencys and inserted some log outputs in the doPut method and the inputstream allways get disconnected at about 8-16% with the mentioned exception.

I tried uploads with several clients: gajim, conversations, jsxc (filesizes: 100 - 300kb)

If i revert only the jetty version to 9.4.35.v20201120 again without changing any other code in OF, it is running again…

Excellent work, are you able to test with the most recent jetty release to see if trouble exists with it too?

I did some tests:
OF is running on Raspi 4 with 4GB Ram.
I use openjdk-11 and first i tried Jetty Version: 9.4.43.v20210629 without success.
Only the older jetty version 9.4.35.v20201120 as dependency was working.
Then i have googled around and read that newer jetty versions have some more checks build in, which might fail, so the stream could be closed to early.
Furthermore i have updated my system to latest packages. (openjdk-11 were also updated)
Now the most recent jetty version 9.4.43.v20210629 seems to work too.

Conclusion: Use the latest openjdk-11 version with the newest jetty 9.4.43.v20210629 .