powered by Jive Software

Strange browser behaviour with localhost

I was always using my test server (on my home PC) Admin Console with http://127.0.0.1:9090 bookmark. So there was no favicon. Today i have changed it to http://wroot:9090 (it’‘s my PC name and Openfire server’'s name). Now i see favicon and Admin Console works fine until i do some editing, try to create or delte group, then it starts to open new tabs (Firefox 2.0.0.3) for every action i try. I use TabMix and it should only launch new tabs for a new domain links.

Can somebody explain such behaviour?

P.S. have changed bookmark to point to localhost. So maybe this depends on hosts settings? Windows 2000.

Hey wroot,

Is this a IE 7 or FF question? I cannot think of something in the server creating such situation.

Regards,

– GAto

Probably Firefox Just i havent seen such behaviour before. And the address is always pointing to http://wroot, so there is no new domain. But it starts to open everything in new tabs after i click Edit or Cancel or other action button in Admin Console.

HI,

is JM-868 solved in 3.0.0-beta or how should a favicon appear?

LG

I havent ever seen the favicon nor at home (using with http://127.0.0.1 address) nor at work using with IP of the server or with the name (have put in in hosts file, cause the dont have DNS). It only started to show up yesterday with Openfire 3.3.0 Beta 1 after i change my url to http://wroot or http://localhost

But the favicon appeared first in Registration plugin’'s web form even without changing my url. Only then i started to manipulate with url to get favicon showing in whole Admin Console.

UPD: no, there was an example of url in Registration options, and it was pointing to wroot, so i have tried this url and then saw the favicon for the first time.

Hi,

so it was added to 331-b1, “http://127.0.0.1:9090/favicon.ico” returns the icon.

As a browser may or may not query a server for a favicon it’'s usually a browser issue if no favicon is displayed.

It could help to add ‘’’’ to all web pages as some browsers may ignore it otherwise.

LG

it2000 wrote:

It could help to add ‘’’’ to all web pages as some browsers may ignore it otherwise.

Yes, was looking for this in sources. This could be maybe easiest way to fix that “problem”