powered by Jive Software

Stuck at log in on admin console

I tried this morning to log in through the Admin Console to add a new user. It has been some time since I last logged in. Login failed repeatedly, so I verified my password (in messenger.script). It was correct.

Then I noticed that when I was using what is the correct password, the page isn’‘t failing so much as reloading. It’'s accepting the password, but not going anywhere.

Hitting the forums, I tried modifying vmoptions (as post http://www.jivesoftware.org/community/thread.jspa?messageID=112814 suggests). That didn’'t help.

I tried upgrading from Jive 2.3.0 to Wildfire 2.6.0. I followed the steps for upgrading, copying the config, SSL, and database files as instructed. Still nothing. I also tried 2.5.1 with no success.

Everything seems to work fine. The webserver is running, and I assume the chat is, too, though I’‘ve been unable to get the old accounts to load. I just can’‘t get past the Admin Console log in to do anything else. I rotated my log files for a clean start, and they’'re not showing any problems.

Does anyone have any suggestions?

Did you try with 2.6.0 or 2.6.0a or (best) 2.6.1? Try again with 2.6.1 and see if it works - several password-related bugs were fixed. Also, make sure that the password key is set. (Alternately, go into the database and put the new password in the password column and blank out the encrypted password column. That should let you get logged in and change the password.)

Wildfire 2.6.1 does not seem to have helped.

I’‘m using the embedded db. I should have mentioned that earlier. I can see the (plaintext) password in wildfire.scripts (which I copied from messenger.scripts). I’‘m pretty sure it’'s not an authentication probelm, as there is clearly a difference when I enter the would-be correct password and one that I know is wrong.

With the correct password, the Admin Console just refreshes. With an incorrect password, I get “Login failed: make sure your username and password are correct and that you’'re an admin or moderator.”

If I just try to set up a new system (default install without copied config or db files), I get an error after the page to set the admin password.

HTTP ERROR: 500

Internal Server Error

RequestURI=/setup/setup-finished.jsp

Powered by Jetty://