Symbol question

I’m testing out Openfire/ Spark and was getting on ok until this, I have one test user who has a pound symbol £ in the password. Any time I try to log on with this account I get an invalid username or password error!

I tried setting up another user with the same password and I get the same error! I’m pulling users from Active Directory so I can’t ask people to change their confidential passwords if they have a £ symbol in them as that would affect the whole company.

Can anyone confirm or deny that the problem is indeed the £ symbol? and more importantly can anyone suggest a fix? Are there any other unsupported symbols?

TIA for any help


We have this problem today, 2 years later.

v 3.6.4

Even though AD, LDAP and Jive work with symbols, Openfire doesn’t

Actually OF-305 is 4 years old. As Openfire supports UTF-8 it should work, but it seems that the password is either not properly hashed on client side or Openfire does not convert it properly.


Turns out this user is using one of { } \ |