powered by Jive Software

TestSQL Settings

When looking at my MS SQL 2005 server that openfire uses, I have noticed that it incessantly pings the server with “Select 1”. In 5 mins, I have had this run 1464 times. I am gessing I can disable this by changing testBeforeUse and testAfterUse in openfire.xml to false. I want to know:

Why does openfire do this test before and after ever SQL requests?

Is there an adverse affect in turning this off?

Thank you

Hi, I have no idea why both properties are set to true. This usually costs performance (a few real µs and CPUµs) and is likely not needed. Anyhow you should set database.defaultProvider.connectionTimeout (the connection lifetime) to a value which is lower than your TCP idle timeout (or a firewall timeout if you have one between Openfire and the database).

Some MySQL users had problems with failed connections and it is usually a good idea for a connection pool to return a working connection instead of a broken connection to avoid application errors.

You can turn both off, but if you set some application/database errors you should re-enable testBeforeUse.

LG