powered by Jive Software

This room is locked from entry until configuration is confirmed

We get this:

This room is locked from entry until configuration is confirmed.

Then our OSX iChat Tiger clients get NO notifications…

Nothing…

Zero…

Zip.

Does anyone have any idea why we would have this issue. We are using OpenLDAP with OSX Server. The groups read fine, the presense works. But our LDAP configuration had to be modified to get it functional.

ideas? anyone?

LOGS:

2009-03-24 11:08:32.597 iChatAgent[7100] WARNING: JabberMessageNode: ignoring unknown child <http://jabber.org/protocol/pubsub#eventevent>
2009-03-24 11:08:32.597 iChatAgent[7100] WARNING: JabberMessageNode: ignoring unknown child <http://jabber.org/protocol/addressaddresses>
2009-03-24 11:08:32.598 iChatAgent[7100] WARNING: JabberMessageNode: Couldn’t parse date ‘2009-03-21T01:16:50.067Z’

8:32.597 iChatAgent[7100] WARNING: JabberMessageNode: ignoring unknown child <http://jabber.org/protocol/pubsub#eventevent>8:32.597 iChatAgent[7100] WARNING: JabberMessageNode: ignoring unknown child <http://jabber.org/protocol/addressaddresses>8:32.598 iChatAgent[7100] WARNING: JabberMessageNode: Couldn’t parse date ‘2009-03-21T01:16:50.067Z’

2009-03-24 11:08:32.646 iChatAgent[7100] WARNING: JConnection: Couldn’t find target for IQ of type get containing ‘jabber:iq:last*query’ ID ‘purple268300ba’

Thanks to anyone who helps…

From a protocol level, I think this happens when you try to configure a room on creation versus just creating an “instant room” (http://xmpp.org/extensions/xep-0045.html#createroom-instant). Your client or code might be sending the message for creating a configured room, but then not dealing with the configuration form it gets back. The server sends that message that you are getting back, I’ve seen it before.

Cheers,

Karthik

Hi

thanks for giving reply,. can to give be details description …

Thank you for the insight. Is it possible to have a default configuration for our internal lan that bypasses any room authentication?

How do you make it so when the users send an invite, it comes as an ‘instant room’?

thanks!

Hi,

I’m not sure about your settings, and I don’t see any OpenFire configuration properties to disable room configuration and only allow instant rooms.

If you’re using your own code, it should be easy to fix it - send the appropriate message as per the XEP.

If you’re using another client, it might be a bug, can you check the source code? Also, use WireShark to monitor the XMPP messages to make sure that this is indeed the problem.

Karthik

Thanks again for your thoughts.

I’ve posted a detailed explanation of our setup and LDAP problems here:

http://www.igniterealtime.org/community/thread/37326?tstart=0

We’re not using our own code, and we were hoping to keep the iChat client generic, but I’m curious how you would implement this fix if it was possible…