powered by Jive Software

Time 3 Hours Out

Has anyone got this same issue? I have maybe a handfull of clients out of 100, that show a timestamp 3 hours different than the actual time! Now, it does not matter what version of spark I install, I have unistalled, cleaned up all existing entries and reinstalled does not fix the problem.

Thanks, Stephen…

I do not say English very well

In case that it can help below in the question.

  • very high Consumption of memoria in the stations of the customer, is this same?

  • hour Has that it stops schemes it

  • You it would know to inform requisi of the hardware of the stations would necessaria for a good functioning?

Thank You

Euler

Hi Stephen,

Spark queries Java and Java queries Windows for the locale and timezone information. I have no idea why this seems to be not working on some clients, it was already discussed in this forum without a result.

The timezone can be changed by “-Duser.timezone=Canada/Mountain”, “-Duser.timezone=GMT-8:00” or similar settings. To add JVM parameters to Spark one needs to create the file “Spark.vmoptions” (not “spark.vmoptions” and not “Spark.vmoptions.txt”) within the same directory as Spark.exe. Only one JVM parameter is allowed within every line.

LG

PS: If you prefer an English user interface and get a localized one you can also add these two lines to Spark.vmoptions:

-Duser.language=en

-Duser.region=US

The latest offline update fixed this issue for me. Maybe this thread will help you.

http://www.igniterealtime.org/forum/thread.jspa?threadID=25619&tstart=0

Having a similar issue… Client computers run a localized version of Windows XP Professional (PT-BR). Time offset between clients and server is -3 hours. Server is set to America/Sao_Paulo (GMT -2 due to DST). Both Server and Clients are set to same Windows TZ (clocks are in sync)

Searched the net and found a page with a Java applet which displays the current timezone being used by JVM. Opening the site from inside clients shows timezone as “America/Rio_Branco”, which is indeed GMT-5. I created “Spark.vmoptions” and tried a couple of possibilities like America/Sao_Paulo, GMT-3:00 and Brazil/East, but Spark still showed the 3 hour difference in message timestamps.

I even tried replacing the JVM zi file (replacing Rio_Branco with Sao_Paulo). That corrected the time in the web clock java applet, but not on Spark (wasn’t it supposed to get the time from the JVM?). Then I decided to re-read the post pertaining to this issue and find out that I had missed something… the Spark.vmoptions does not work with .MSI installs (that’s what I was using). Reinstalled using the .EXE package and now it’s working!